GESTLIV
Manipulation des éléments accessibles

Pour manipuler un élément du composant (fenêtre, etc.) par programmation, il suffit de manipuler l'élément comme s'il s'agissait d'un élément créé dans le projet :

- pour appeler une procédure : utilisez la syntaxe habituelle :
ProcédureDuComposant(Param1,Param2)

- pour utiliser une classe : déclarer une variable du type de la classe :
MaVariable est un objet ClasseDuComposant
La variable s'utilise par la suite comme une variable objet normale.

- pour ouvrir une fenêtre : utilisez par exemple la fonction Ouvre en passant si nécessaire les paramètres attendus par cette fenêtre.
Ouvre(FenêtreDuComposant [, Param1, Param2])

- pour imprimer un état : utilisez la fonction iImprimeEtat en passant si nécessaire les paramètres attendus par cet état.
iImprimeEtat(EtatComposant [, Param1, Param2])

Les entrées/sorties du composant


Les entrées/sorties du composant

about

Procedures globales de odeiscnt


about


Procedures globales de odeiscnt

WINDEV_RTFLIENDEBUT001205pg_assignemagWINDEV_RTFLIENFIN001205

WINDEV_RTFLIENDEBUT001206pg_balanceWINDEV_RTFLIENFIN001206

WINDEV_RTFLIENDEBUT001207pg_barre_titreWINDEV_RTFLIENFIN001207

WINDEV_RTFLIENDEBUT001208pg_calcul_indiceWINDEV_RTFLIENFIN001208

WINDEV_RTFLIENDEBUT001209pg_carrondiWINDEV_RTFLIENFIN001209

WINDEV_RTFLIENDEBUT001210pg_cartepuceWINDEV_RTFLIENFIN001210

WINDEV_RTFLIENDEBUT001211pg_Charge_pagegardeWINDEV_RTFLIENFIN001211

WINDEV_RTFLIENDEBUT001212pg_Code_CINTERNEWINDEV_RTFLIENFIN001212

WINDEV_RTFLIENDEBUT001213pg_CodeBarre128WINDEV_RTFLIENFIN001213

WINDEV_RTFLIENDEBUT001214pg_CODEBARREEAN13WINDEV_RTFLIENFIN001214

WINDEV_RTFLIENDEBUT001215pg_CodeBarreEan8WINDEV_RTFLIENFIN001215

WINDEV_RTFLIENDEBUT001216pg_Controle_passwordWINDEV_RTFLIENFIN001216

WINDEV_RTFLIENDEBUT001217pg_coulinWINDEV_RTFLIENFIN001217

WINDEV_RTFLIENDEBUT001218pg_couloffWINDEV_RTFLIENFIN001218

WINDEV_RTFLIENDEBUT001219pg_dateenclairWINDEV_RTFLIENFIN001219

WINDEV_RTFLIENDEBUT001220pg_DebugWINDEV_RTFLIENFIN001220

WINDEV_RTFLIENDEBUT001221pg_derniernumeroWINDEV_RTFLIENFIN001221

WINDEV_RTFLIENDEBUT001222pg_echapWINDEV_RTFLIENFIN001222

WINDEV_RTFLIENDEBUT001223pg_Expens_RefWINDEV_RTFLIENFIN001223

WINDEV_RTFLIENDEBUT001224pg_Facture_Imprime_A_SupprimerWINDEV_RTFLIENFIN001224

WINDEV_RTFLIENDEBUT001225pg_FicAjouteWINDEV_RTFLIENFIN001225

WINDEV_RTFLIENDEBUT001226pg_FicModifieWINDEV_RTFLIENFIN001226

WINDEV_RTFLIENDEBUT001227pg_FicSupprimeWINDEV_RTFLIENFIN001227

WINDEV_RTFLIENDEBUT001228pg_fifoWINDEV_RTFLIENFIN001228

WINDEV_RTFLIENDEBUT001229pg_ImpCodeBarreWINDEV_RTFLIENFIN001229

WINDEV_RTFLIENDEBUT001230pg_Imprime_FactureWINDEV_RTFLIENFIN001230

WINDEV_RTFLIENDEBUT001231pg_Imprime_WordWINDEV_RTFLIENFIN001231

pg_Ini_Ecrit

pg_ini_ecrit_com

pg_ini_ecrit_edi

pg_Ini_Ecrit_Inv

pg_ini_lit

pg_ini_lit_com

pg_ini_lit_edi

pg_Ini_Lit_Inv

pg_Init_pagegarde

pg_InitWord

pg_Lit_selmai

pg_MODIFLANGUE

pg_MoisEnClair

pg_MoisJour

pg_param_email

pg_params_email

pg_presence_carte

pg_RADProjetInit

pg_rech_qtemag

pg_rech_tarif

pg_rech_venmag

pg_rechindice1

pg_rechlecteur

pg_rechphoto

pg_remplace1

pg_Rend_Cle_EAN13

pg_Rend_CSTOCK

pg_Rend_DateCodee

pg_Rend_Euro

pg_Rend_NumCde

pg_Saisiemp

pg_sversion

pg_tempo_ac_ediint

pg_tempo_APV

pg_tempo_cc_vis

pg_tempo_cfrep_sai

pg_tempo_com_pro

pg_tempo_com_sai

pg_tempo_com_vendresp

pg_tempo_Compta

pg_tempo_conf_four

pg_tempo_conso_inv_maj

pg_tempo_controle_entrees_mag

pg_tempo_controle_invent_mag

pg_tempo_controle_transfert

pg_tempo_ctrl_dernent

pg_tempo_correct_invent_mag

pg_tempo_ecart_invent_mag

Pg_tempo_st_edifour

pg_tempo_envoi_invent_mag

pg_tempo_etat_ref

Pg_tempo_Etiq

pg_tempo_fabrication

pg_tempo_Fact_D_Cinterne

pg_tempo_gesfact

pg_tempo_lc_vis

pg_tempo_marmotte

pg_tempo_mouchard

pg_tempo_oper_stock

pg_tempo_pj_sai

pg_tempo_pj_vis

pg_tempo_portcdemag

pg_tempo_reas_orig

pg_tempo_reed_fac_gros

pg_tempo_reglem_recap

pg_tempo_remise_mag

pg_tempo_sav

pg_tempo_situ_vte

pg_tempo_situvtedes

pg_tempo_st_mag

pg_tempo_st_maj_logi

pg_tempo_stat

pg_tempo_stat_conso

WINDEV_RTFLIENDEBUT001100pg_tempo_Stat_conso_MagRepliqueWINDEV_RTFLIENFIN001100

WINDEV_RTFLIENDEBUT001101pg_tempo_stat_fourWINDEV_RTFLIENFIN001101

WINDEV_RTFLIENDEBUT001102pg_tempo_stat_gestionWINDEV_RTFLIENFIN001102

WINDEV_RTFLIENDEBUT001103pg_tempo_Stat_HaussePxWINDEV_RTFLIENFIN001103

WINDEV_RTFLIENDEBUT001104pg_tempo_stvaloWINDEV_RTFLIENFIN001104

WINDEV_RTFLIENDEBUT001105pg_tempo_taux_rupture_fourWINDEV_RTFLIENFIN001105

WINDEV_RTFLIENDEBUT001106pg_tempo_traite_autoWINDEV_RTFLIENFIN001106

WINDEV_RTFLIENDEBUT001107pg_tempo_util_confcentWINDEV_RTFLIENFIN001107

WINDEV_RTFLIENDEBUT001108pg_temporaireWINDEV_RTFLIENFIN001108

WINDEV_RTFLIENDEBUT001109pg_versmonnaie1WINDEV_RTFLIENFIN001109

WINDEV_RTFLIENDEBUT001110pg_versmonnaie2WINDEV_RTFLIENFIN001110

WINDEV_RTFLIENDEBUT001111pg_ficVersExcelWINDEV_RTFLIENFIN001111

WINDEV_RTFLIENDEBUT001112Pg_Tempo_Stat_Etat_CommercialWINDEV_RTFLIENFIN001112

WINDEV_RTFLIENDEBUT001113pg_Ini_lit_GestionWINDEV_RTFLIENFIN001113

WINDEV_RTFLIENDEBUT001114pg_Ini_Ecrit_GestionWINDEV_RTFLIENFIN001114

WINDEV_RTFLIENDEBUT001115pg_tempo_Stat_Perf_RefFourWINDEV_RTFLIENFIN001115

WINDEV_RTFLIENDEBUT001116pg_ini_ecrit_choixWINDEV_RTFLIENFIN001116

WINDEV_RTFLIENDEBUT001117pg_ini_lit_choixWINDEV_RTFLIENFIN001117

WINDEV_RTFLIENDEBUT001118pg_tempo_u_valoinventWINDEV_RTFLIENFIN001118

WINDEV_RTFLIENDEBUT001119pg_tempo_HpMag_RefWINDEV_RTFLIENFIN001119

WINDEV_RTFLIENDEBUT001120pg_Dern_Entree_StockWINDEV_RTFLIENFIN001120

WINDEV_RTFLIENDEBUT001121pg_Dern_EtiquetteWINDEV_RTFLIENFIN001121

WINDEV_RTFLIENDEBUT001122pg_LecturePremierWINDEV_RTFLIENFIN001122

WINDEV_RTFLIENDEBUT001123pg_LectureDernierWINDEV_RTFLIENFIN001123

WINDEV_RTFLIENDEBUT001124pg_Rech_Stock_MagWINDEV_RTFLIENFIN001124

WINDEV_RTFLIENDEBUT001125pg_QteEnCdeFourWINDEV_RTFLIENFIN001125

WINDEV_RTFLIENDEBUT001126pg_Liste_CodesWINDEV_RTFLIENFIN001126

WINDEV_RTFLIENDEBUT001127pg_Liste_FournWINDEV_RTFLIENFIN001127

WINDEV_RTFLIENDEBUT001128pg_RechQteCentWINDEV_RTFLIENFIN001128

WINDEV_RTFLIENDEBUT001129pg_tempo_cde_speWINDEV_RTFLIENFIN001129

WINDEV_RTFLIENDEBUT001130pg_tempo_fact_diff_centraleWINDEV_RTFLIENFIN001130

WINDEV_RTFLIENDEBUT001131pg_tempo_comptachat_magWINDEV_RTFLIENFIN001131

WINDEV_RTFLIENDEBUT001132pg_tempo_trancomptaWINDEV_RTFLIENFIN001132

WINDEV_RTFLIENDEBUT001133pg_tempo_ecarts_restantWINDEV_RTFLIENFIN001133

WINDEV_RTFLIENDEBUT001134pg_tempo_export_vtemagWINDEV_RTFLIENFIN001134

WINDEV_RTFLIENDEBUT001135pg_Liste_Fourn_TousWINDEV_RTFLIENFIN001135

WINDEV_RTFLIENDEBUT001136pg_tempo_st_refmagWINDEV_RTFLIENFIN001136

WINDEV_RTFLIENDEBUT001137pg_STNONINT_ANCIEN1WINDEV_RTFLIENFIN001137

WINDEV_RTFLIENDEBUT001138pg_tempo_reas_st_impWINDEV_RTFLIENFIN001138

WINDEV_RTFLIENDEBUT001139pg_Rech_Qte_PrepWINDEV_RTFLIENFIN001139

WINDEV_RTFLIENDEBUT001140pg_AssigneMag_ParamsWINDEV_RTFLIENFIN001140

WINDEV_RTFLIENDEBUT001141pg_tempo_comptachat_st_magWINDEV_RTFLIENFIN001141

WINDEV_RTFLIENDEBUT001142pg_Tempo_UtilitairesWINDEV_RTFLIENFIN001142

WINDEV_RTFLIENDEBUT001143pg_tempo_gest_vendWINDEV_RTFLIENFIN001143

WINDEV_RTFLIENDEBUT001144pg_tempo_traiteWINDEV_RTFLIENFIN001144

WINDEV_RTFLIENDEBUT001145pg_tempo_evo_ca_magWINDEV_RTFLIENFIN001145

WINDEV_RTFLIENDEBUT001146pg_tempo_li_recepWINDEV_RTFLIENFIN001146

WINDEV_RTFLIENDEBUT001147pg_STNONINT_ANCIEN2WINDEV_RTFLIENFIN001147

WINDEV_RTFLIENDEBUT001148pg_RechDate_NbMoisWINDEV_RTFLIENFIN001148

WINDEV_RTFLIENDEBUT001149pg_STNONINT_ANCIEN3WINDEV_RTFLIENFIN001149

WINDEV_RTFLIENDEBUT001150pg_tempo_suivi_detWINDEV_RTFLIENFIN001150

WINDEV_RTFLIENDEBUT001151pg_Liste_GroupFournWINDEV_RTFLIENFIN001151

WINDEV_RTFLIENDEBUT001152pg_RechDate_NbJoursWINDEV_RTFLIENFIN001152

WINDEV_RTFLIENDEBUT001153pg_tempo_partcamgWINDEV_RTFLIENFIN001153

WINDEV_RTFLIENDEBUT001154pg_Rech_Num_PIECECPTWINDEV_RTFLIENFIN001154

WINDEV_RTFLIENDEBUT001155pg_tempo_SuiviBdlWINDEV_RTFLIENFIN001155

WINDEV_RTFLIENDEBUT001156pg_cof_lettre_vers_entierWINDEV_RTFLIENFIN001156

WINDEV_RTFLIENDEBUT001157pg_cof_entier_vers_lettreWINDEV_RTFLIENFIN001157

WINDEV_RTFLIENDEBUT001158pg_cof_rech_zoneWINDEV_RTFLIENFIN001158

WINDEV_RTFLIENDEBUT001159pg_cof_coordonnéesWINDEV_RTFLIENFIN001159

WINDEV_RTFLIENDEBUT001160pg_Ajout_MouchardWINDEV_RTFLIENFIN001160

WINDEV_RTFLIENDEBUT001161pg_tempo_coffreWINDEV_RTFLIENFIN001161

WINDEV_RTFLIENDEBUT001162pg_ini_lit_ediautoWINDEV_RTFLIENFIN001162

WINDEV_RTFLIENDEBUT001163pg_ini_ecrit_ediautoWINDEV_RTFLIENFIN001163

WINDEV_RTFLIENDEBUT001164pg_cof_rend_CSTOCKWINDEV_RTFLIENFIN001164

WINDEV_RTFLIENDEBUT001165pg_cof_rend_ancréf_CSTOCKWINDEV_RTFLIENFIN001165

WINDEV_RTFLIENDEBUT001166pg_cof_rend_gencod_CSTOCKWINDEV_RTFLIENFIN001166

WINDEV_RTFLIENDEBUT001167pg_cof_affiche_emplacementWINDEV_RTFLIENFIN001167

WINDEV_RTFLIENDEBUT001168pg_cof_rech_empl_prepliliWINDEV_RTFLIENFIN001168

WINDEV_RTFLIENDEBUT001169pg_tempo_reaselcoWINDEV_RTFLIENFIN001169

WINDEV_RTFLIENDEBUT001170pg_tempo_impstideWINDEV_RTFLIENFIN001170

WINDEV_RTFLIENDEBUT001171pg_cof_rech_empl_sgligneWINDEV_RTFLIENFIN001171

WINDEV_RTFLIENDEBUT001172pg_tempo_st_majmagWINDEV_RTFLIENFIN001172

WINDEV_RTFLIENDEBUT001173pg_Rend_EtiquetteWINDEV_RTFLIENFIN001173

WINDEV_RTFLIENDEBUT001174pg_Rend_GencodeWINDEV_RTFLIENFIN001174

WINDEV_RTFLIENDEBUT001175pg_Rend_AncRéfWINDEV_RTFLIENFIN001175

WINDEV_RTFLIENDEBUT001176pg_tempo_u_mod_refWINDEV_RTFLIENFIN001176

WINDEV_RTFLIENDEBUT001177pg_tempo_imprefreWINDEV_RTFLIENFIN001177

WINDEV_RTFLIENDEBUT001178pg_tempo_refre_visWINDEV_RTFLIENFIN001178

WINDEV_RTFLIENDEBUT001179pg_tempo_improjetWINDEV_RTFLIENFIN001179

WINDEV_RTFLIENDEBUT001180pg_SQLModifieWINDEV_RTFLIENFIN001180

WINDEV_RTFLIENDEBUT001181pg_SQLRubriquesWINDEV_RTFLIENFIN001181

WINDEV_RTFLIENDEBUT001182pg_SQLValuesWINDEV_RTFLIENFIN001182

WINDEV_RTFLIENDEBUT001183pg_SQLSupprimeWINDEV_RTFLIENFIN001183

WINDEV_RTFLIENDEBUT001184pg_rectifheaderWINDEV_RTFLIENFIN001184

WINDEV_RTFLIENDEBUT001185pg_tempo_robbezWINDEV_RTFLIENFIN001185

WINDEV_RTFLIENDEBUT001186pg_SQLEXECWINDEV_RTFLIENFIN001186

WINDEV_RTFLIENDEBUT001187pg_Rech_EtiqNonIntégréWINDEV_RTFLIENFIN001187

WINDEV_RTFLIENDEBUT001188pg_tempo_edi_importWINDEV_RTFLIENFIN001188

WINDEV_RTFLIENDEBUT001189pg_Change_SociétéWINDEV_RTFLIENFIN001189

WINDEV_RTFLIENDEBUT001190pg_Rech_Vte_MagWINDEV_RTFLIENFIN001190

WINDEV_RTFLIENDEBUT001191pg_Création_SociétéWINDEV_RTFLIENFIN001191

WINDEV_RTFLIENDEBUT001192pg_Calcul_TABTARWINDEV_RTFLIENFIN001192

WINDEV_RTFLIENDEBUT001193pg_Rech_CoefVte_GamWINDEV_RTFLIENFIN001193

WINDEV_RTFLIENDEBUT001194pg_Cof_Rech_EmplacemtWINDEV_RTFLIENFIN001194

WINDEV_RTFLIENDEBUT001195pg_STNONINTWINDEV_RTFLIENFIN001195

WINDEV_RTFLIENDEBUT001196pg_ini_ecrit_comptaWINDEV_RTFLIENFIN001196

WINDEV_RTFLIENDEBUT001197pg_ini_lit_comptaWINDEV_RTFLIENFIN001197

WINDEV_RTFLIENDEBUT001198pg_Liste_MagWINDEV_RTFLIENFIN001198

WINDEV_RTFLIENDEBUT001199pg_Liste_GroupMagWINDEV_RTFLIENFIN001199

WINDEV_RTFLIENDEBUT001200pg_Liste_Mag_InventWINDEV_RTFLIENFIN001200

WINDEV_RTFLIENDEBUT001201pg_tempo_st_pyragWINDEV_RTFLIENFIN001201

WINDEV_RTFLIENDEBUT001202pg_tempo_ecartpxWINDEV_RTFLIENFIN001202

WINDEV_RTFLIENDEBUT001203pg_tempo_ctrlpxWINDEV_RTFLIENFIN001203

WINDEV_RTFLIENDEBUT001204pg_Rech_QteCdeFourWINDEV_RTFLIENFIN001204


Procédure 'pg_assignemag'
Procédure pg_assignemag()
Procedure permettant d'effectuer l'assigne du fichier
stock d'un magasin.
A partir d'un code magasin et du nom de son serveur :
. recherche existance fichier sur logibij/fichier si trouve
alors assigne.
. Si pas recherche existance sur logibij/fic+xxx si trouve
alors assigne.
. Si pas trouvee : reponse trouvemag a faux.


Procédure 'pg_balance'
Syntaxe :
pg_balance (<balance_poids>)

Paramètres :
balance_poids : <indiquez ici le rôle de balance_poids>
Valeur de retour :
Aucune


Procédure 'pg_barre_titre'
Syntaxe :
pg_barre_titre (<barre_titre_titre>)

Paramètres :
barre_titre_titre : <indiquez ici le rôle de barre_titre_titre>
Valeur de retour :
Aucune


Procédure 'pg_calcul_indice'
Syntaxe :
[ <Résultat> = ] pg_calcul_indice (<calcul_indice_ind>)

Paramètres :
calcul_indice_ind : <indiquez ici le rôle de calcul_indice_ind>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_carrondi'


Procédure 'pg_cartepuce'
Syntaxe :
pg_cartepuce (<cartepuce_vendeur>, <cartepuce_motdepasse>)

Paramètres :
cartepuce_vendeur : <indiquez ici le rôle de cartepuce_vendeur>
cartepuce_motdepasse : <indiquez ici le rôle de cartepuce_motdepasse>
Valeur de retour :
Aucune


Procédure 'pg_Charge_pagegarde'
Syntaxe :
pg_Charge_pagegarde ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Code_CINTERNE'
Syntaxe :
pg_Code_CINTERNE (<code_cinterne_ValEntree>)

Paramètres :
code_cinterne_ValEntree : <indiquez ici le rôle de code_cinterne_ValEntree>
Valeur de retour :
Aucune


Procédure 'pg_CodeBarre128'
creation code barre code 128


Procédure 'pg_CODEBARREEAN13'
Procédure pg_CODEBARREEAN13()
***************************************
PROCEDURE D'IMPRESSION DE CODE BARRE
NORME : EAN 13
***************************************


Procédure 'pg_CodeBarreEan8'
Syntaxe :
pg_CodeBarreEan8 (<CodeBarreEan8_CodeBar>, <CodeBarreEan8_col>, <CodeBarreEan8_lig>[, <CodeBarreEan8_Hauteur>[, <CodeBarreEan8_Largeur>[, <CodeBarreEan8_HautDec>]]])

Paramètres :
CodeBarreEan8_CodeBar : <indiquez ici le rôle de CodeBarreEan8_CodeBar>
CodeBarreEan8_col : <indiquez ici le rôle de CodeBarreEan8_col>
CodeBarreEan8_lig : <indiquez ici le rôle de CodeBarreEan8_lig>
CodeBarreEan8_Hauteur : <indiquez ici le rôle de CodeBarreEan8_Hauteur>
CodeBarreEan8_Largeur : <indiquez ici le rôle de CodeBarreEan8_Largeur>
CodeBarreEan8_HautDec : <indiquez ici le rôle de CodeBarreEan8_HautDec>
Valeur de retour :
Aucune


Procédure 'pg_Controle_password'
Syntaxe :
[ <Résultat> = ] pg_Controle_password (<Controle_password_Nom_Fenetre>)

Paramètres :
Controle_password_Nom_Fenetre : <indiquez ici le rôle de Controle_password_Nom_Fenetre>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_coulin'
Syntaxe :
pg_coulin (<coulin_champ>)

Paramètres :
coulin_champ : <indiquez ici le rôle de coulin_champ>
Valeur de retour :
Aucune


Procédure 'pg_couloff'
Syntaxe :
pg_couloff (<couloff_champ>)

Paramètres :
couloff_champ : <indiquez ici le rôle de couloff_champ>
Valeur de retour :
Aucune


Procédure 'pg_dateenclair'
A partir d'un date sous la forme JJMMAAAA
pg_dateenclair procédure renvoie la date en clair
ex 14021997 devient Vendredi 14 Février 1997


Procédure 'pg_Debug'
Syntaxe :
pg_Debug (<Debug_Texte>)

Paramètres :
Debug_Texte : <indiquez ici le rôle de Debug_Texte>
Valeur de retour :
Aucune


Procédure 'pg_derniernumero'
Syntaxe :
[ <Résultat> = ] pg_derniernumero (<derniernumero_type>)

Paramètres :
derniernumero_type : <indiquez ici le rôle de derniernumero_type>
Valeur de retour :
entier : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_echap'
Syntaxe :
[ <Résultat> = ] pg_echap ()

Paramètres :
Aucun
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Expens_Ref'
Mise a longueur numetiq=7 caractères


Procédure 'pg_Facture_Imprime_A_Supprimer'
Syntaxe :
pg_Facture_Imprime_A_Supprimer ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_FicAjoute'


Procédure 'pg_FicModifie'


Procédure 'pg_FicSupprime'


Procédure 'pg_fifo'
recherche et lit le dernier article acheté (sur datefac)
a partir de (code-four+ref.four)
renvoi (resu_b=vrai et stock.nmagasin et stock.numetiq) si un article a été trouve


Procédure 'pg_ImpCodeBarre'
Syntaxe :
[ <Résultat> = ] pg_ImpCodeBarre (<ImpCodeBarre_Lig>, <ImpCodeBarre_Col>, <ImpCodeBarre_nHauteur>, <ImpCodeBarre_nLargeur>, <ImpCodeBarre_nHautDec>, <ImpCodeBarre_szCodeBarre>[, <ImpCodeBarre_Decalage>])

Paramètres :
ImpCodeBarre_Lig : <indiquez ici le rôle de ImpCodeBarre_Lig>
ImpCodeBarre_Col : <indiquez ici le rôle de ImpCodeBarre_Col>
ImpCodeBarre_nHauteur : <indiquez ici le rôle de ImpCodeBarre_nHauteur>
ImpCodeBarre_nLargeur : <indiquez ici le rôle de ImpCodeBarre_nLargeur>
ImpCodeBarre_nHautDec : <indiquez ici le rôle de ImpCodeBarre_nHautDec>
ImpCodeBarre_szCodeBarre : <indiquez ici le rôle de ImpCodeBarre_szCodeBarre>
ImpCodeBarre_Decalage : <indiquez ici le rôle de ImpCodeBarre_Decalage>
Valeur de retour :
réel : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Imprime_Facture'
Syntaxe :
[ <Résultat> = ] pg_Imprime_Facture (<Imprime_Facture_TypeDoc>, <Imprime_Facture_NoDoc>, <Imprime_Facture_Int_Dest>[, <Imprime_Facture_Tri>])

Paramètres :
Imprime_Facture_TypeDoc : <indiquez ici le rôle de Imprime_Facture_TypeDoc>
Imprime_Facture_NoDoc : <indiquez ici le rôle de Imprime_Facture_NoDoc>
Imprime_Facture_Int_Dest : <indiquez ici le rôle de Imprime_Facture_Int_Dest>
Imprime_Facture_Tri : <indiquez ici le rôle de Imprime_Facture_Tri>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Imprime_Word'
Syntaxe :
pg_Imprime_Word (<Imprime_Word_NumFac>[, <Imprime_Word_NomFicWord>])

Paramètres :
Imprime_Word_NumFac : <indiquez ici le rôle de Imprime_Word_NumFac>
Imprime_Word_NomFicWord : <indiquez ici le rôle de Imprime_Word_NomFicWord>
Valeur de retour :
Aucune


Procédure 'pg_Ini_Ecrit'
Syntaxe :
pg_Ini_Ecrit (<Ini_Ecrit_Section>, <Ini_Ecrit_Entree>, <Ini_Ecrit_Valeur>)

Paramètres :
Ini_Ecrit_Section : <indiquez ici le rôle de Ini_Ecrit_Section>
Ini_Ecrit_Entree : <indiquez ici le rôle de Ini_Ecrit_Entree>
Ini_Ecrit_Valeur : <indiquez ici le rôle de Ini_Ecrit_Valeur>
Valeur de retour :
Aucune


Procédure 'pg_ini_ecrit_com'
Syntaxe :
pg_ini_ecrit_com (<PSection>, <PEntree>, <PValeur>)

Paramètres :
PSection : <indiquez ici le rôle de PSection>
PEntree : <indiquez ici le rôle de PEntree>
PValeur : <indiquez ici le rôle de PValeur>
Valeur de retour :
Aucune


Procédure 'pg_ini_ecrit_edi'
Syntaxe :
pg_ini_ecrit_edi (<PSection>, <PEntree>, <PValeur>, <PCFourn>)

Paramètres :
PSection : <indiquez ici le rôle de PSection>
PEntree : <indiquez ici le rôle de PEntree>
PValeur : <indiquez ici le rôle de PValeur>
PCFourn : <indiquez ici le rôle de PCFourn>
Valeur de retour :
Aucune


Procédure 'pg_Ini_Ecrit_Inv'
Syntaxe :
pg_Ini_Ecrit_Inv (<Ini_Ecrit_Inv_Section>, <Ini_Ecrit_Inv_Entree>, <Ini_Ecrit_Inv_Valeur>)

Paramètres :
Ini_Ecrit_Inv_Section : <indiquez ici le rôle de Ini_Ecrit_Inv_Section>
Ini_Ecrit_Inv_Entree : <indiquez ici le rôle de Ini_Ecrit_Inv_Entree>
Ini_Ecrit_Inv_Valeur : <indiquez ici le rôle de Ini_Ecrit_Inv_Valeur>
Valeur de retour :
Aucune


Procédure 'pg_ini_lit'
Syntaxe :
[ <Résultat> = ] pg_ini_lit (<ini_lit_Section>, <ini_lit_Entree>)

Paramètres :
ini_lit_Section : <indiquez ici le rôle de ini_lit_Section>
ini_lit_Entree : <indiquez ici le rôle de ini_lit_Entree>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_ini_lit_com'
Syntaxe :
[ <Résultat> = ] pg_ini_lit_com (<PSection>, <PEntree>)

Paramètres :
PSection : <indiquez ici le rôle de PSection>
PEntree : <indiquez ici le rôle de PEntree>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_ini_lit_edi'
Syntaxe :
[ <Résultat> = ] pg_ini_lit_edi (<Section>, <Entree>, <CFourn>)

Paramètres :
Section : <indiquez ici le rôle de Section>
Entree : <indiquez ici le rôle de Entree>
CFourn : <indiquez ici le rôle de CFourn>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Ini_Lit_Inv'
Syntaxe :
[ <Résultat> = ] pg_Ini_Lit_Inv (<Ini_Lit_Inv_Section>, <Ini_Lit_Inv_Entree>)

Paramètres :
Ini_Lit_Inv_Section : <indiquez ici le rôle de Ini_Lit_Inv_Section>
Ini_Lit_Inv_Entree : <indiquez ici le rôle de Ini_Lit_Inv_Entree>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Init_pagegarde'
Syntaxe :
pg_Init_pagegarde ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_InitWord'
Syntaxe :
[ <Résultat> = ] pg_InitWord (<InitWord_Mail>, <InitWord_WordVisible>)

Paramètres :
InitWord_Mail : <indiquez ici le rôle de InitWord_Mail>
InitWord_WordVisible : <indiquez ici le rôle de InitWord_WordVisible>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Lit_selmai'
Syntaxe :
pg_Lit_selmai (<Lit_selmai_SELMAI>, <Lit_selmai_ch>)

Paramètres :
Lit_selmai_SELMAI : <indiquez ici le rôle de Lit_selmai_SELMAI>
Lit_selmai_ch : <indiquez ici le rôle de Lit_selmai_ch>
Valeur de retour :
Aucune


Procédure 'pg_MODIFLANGUE'
Syntaxe :
pg_MODIFLANGUE (<MODIFLANGUE_Groupe>, <MODIFLANGUE_Entree>, <MODIFLANGUE_Param>)

Paramètres :
MODIFLANGUE_Groupe : <indiquez ici le rôle de MODIFLANGUE_Groupe>
MODIFLANGUE_Entree : <indiquez ici le rôle de MODIFLANGUE_Entree>
MODIFLANGUE_Param : <indiquez ici le rôle de MODIFLANGUE_Param>
Valeur de retour :
Aucune


Procédure 'pg_MoisEnClair'
A partir d'un date sous la forme JJMMAAAA
pg_MoisEnClair procédure renvoie le mois en clair
ex 14021997 devient Février 1997


Procédure 'pg_MoisJour'
Syntaxe :
[ <Résultat> = ] pg_MoisJour (<MoisJour_ValEntree>)

Paramètres :
MoisJour_ValEntree : <indiquez ici le rôle de MoisJour_ValEntree>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_param_email'
NE PAS UTILISER CETTE FONCTION
UTILISER PARAMS_EMAIL()


Procédure 'pg_params_email'
Recherche parametres de connection email dans c:.txt


Procédure 'pg_presence_carte'
Syntaxe :
pg_presence_carte ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_RADProjetInit'
Syntaxe :
pg_RADProjetInit ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_rech_qtemag'
Syntaxe :
pg_rech_qtemag (<rech_qtemag_cinterne>, <rech_qtemag_cfourniss>, <rech_qtemag_reffour>, <rech_qtemag_cfamille>, <rech_qtemag_qtestomag_r>, <rech_qtemag_datemag_c>)

Paramètres :
rech_qtemag_cinterne : <indiquez ici le rôle de rech_qtemag_cinterne>
rech_qtemag_cfourniss : <indiquez ici le rôle de rech_qtemag_cfourniss>
rech_qtemag_reffour : <indiquez ici le rôle de rech_qtemag_reffour>
rech_qtemag_cfamille : <indiquez ici le rôle de rech_qtemag_cfamille>
rech_qtemag_qtestomag_r : <indiquez ici le rôle de rech_qtemag_qtestomag_r>
rech_qtemag_datemag_c : <indiquez ici le rôle de rech_qtemag_datemag_c>
Valeur de retour :
Aucune


Procédure 'pg_rech_tarif'
Syntaxe :
pg_rech_tarif (<RT_Contrmarq_c>, <RT_Cfamille_c>, <RT_Indice_e>)

Paramètres :
RT_Contrmarq_c : <indiquez ici le rôle de RT_Contrmarq_c>
RT_Cfamille_c : <indiquez ici le rôle de RT_Cfamille_c>
RT_Indice_e : <indiquez ici le rôle de RT_Indice_e>
Valeur de retour :
Aucune


Procédure 'pg_rech_venmag'
Syntaxe :
pg_rech_venmag (<rech_venmag_cinterne>, <rech_venmag_cfourniss>, <rech_venmag_reffour>, <rech_venmag_cfamille>, <rech_venmag_qtevenmag_r>)

Paramètres :
rech_venmag_cinterne : <indiquez ici le rôle de rech_venmag_cinterne>
rech_venmag_cfourniss : <indiquez ici le rôle de rech_venmag_cfourniss>
rech_venmag_reffour : <indiquez ici le rôle de rech_venmag_reffour>
rech_venmag_cfamille : <indiquez ici le rôle de rech_venmag_cfamille>
rech_venmag_qtevenmag_r : <indiquez ici le rôle de rech_venmag_qtevenmag_r>
Valeur de retour :
Aucune


Procédure 'pg_rechindice1'
Syntaxe :
pg_rechindice1 ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_rechlecteur'
Syntaxe :
[ <Résultat> = ] pg_rechlecteur ()

Paramètres :
Aucun
Valeur de retour :
entier : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_rechphoto'
Syntaxe :
pg_rechphoto (<rechphoto_cfourniss>, <rechphoto_reffour>, <rechphoto_photo>)

Paramètres :
rechphoto_cfourniss : <indiquez ici le rôle de rechphoto_cfourniss>
rechphoto_reffour : <indiquez ici le rôle de rechphoto_reffour>
rechphoto_photo : <indiquez ici le rôle de rechphoto_photo>
Valeur de retour :
Aucune


Procédure 'pg_remplace1'
Syntaxe :
pg_remplace1 (<remplace1_Ch>, <remplace1_ChIni>, <remplace1_ChRemp>)

Paramètres :
remplace1_Ch : <indiquez ici le rôle de remplace1_Ch>
remplace1_ChIni : <indiquez ici le rôle de remplace1_ChIni>
remplace1_ChRemp : <indiquez ici le rôle de remplace1_ChRemp>
Valeur de retour :
Aucune


Procédure 'pg_Rend_Cle_EAN13'
Syntaxe :
[ <Résultat> = ] pg_Rend_Cle_EAN13 (<Rend_Cle_EAN13_eCodeBar>)

Paramètres :
Rend_Cle_EAN13_eCodeBar : <indiquez ici le rôle de Rend_Cle_EAN13_eCodeBar>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Rend_CSTOCK'


Procédure 'pg_Rend_DateCodee'
Syntaxe :
[ <Résultat> = ] pg_Rend_DateCodee (<Rend_DateCodee_Date>)

Paramètres :
Rend_DateCodee_Date : <indiquez ici le rôle de Rend_DateCodee_Date>
Valeur de retour :
chaîne fixe : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Rend_Euro'
Syntaxe :
[ <Résultat> = ] pg_Rend_Euro (<Rend_Euro_ValeurFF>)

Paramètres :
Rend_Euro_ValeurFF : <indiquez ici le rôle de Rend_Euro_ValeurFF>
Valeur de retour :
monétaire : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Rend_NumCde'


Procédure 'pg_Saisiemp'
Syntaxe :
pg_Saisiemp ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_sversion'
Syntaxe :
pg_sversion (<sversion_opes_c>, <sversion_spack>)

Paramètres :
sversion_opes_c : <indiquez ici le rôle de sversion_opes_c>
sversion_spack : <indiquez ici le rôle de sversion_spack>
Valeur de retour :
Aucune


Procédure 'pg_tempo_ac_ediint'
Syntaxe :
pg_tempo_ac_ediint ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_APV'
Syntaxe :
pg_tempo_APV ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_cc_vis'
Syntaxe :
pg_tempo_cc_vis ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_cfrep_sai'
Syntaxe :
pg_tempo_cfrep_sai ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_com_pro'
Syntaxe :
pg_tempo_com_pro ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_com_sai'
Syntaxe :
pg_tempo_com_sai ()


Procédure 'pg_tempo_com_vendresp'
Syntaxe :
pg_tempo_com_vendresp ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_Compta'
Syntaxe :
pg_tempo_Compta ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_conf_four'
Syntaxe :
pg_tempo_conf_four ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_conso_inv_maj'
Syntaxe :
pg_tempo_conso_inv_maj ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_controle_entrees_mag'
Syntaxe :
pg_tempo_controle_entrees_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_controle_invent_mag'
Syntaxe :
pg_tempo_controle_invent_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_controle_transfert'
Syntaxe :
pg_tempo_controle_transfert ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_ctrl_dernent'
Syntaxe :
pg_tempo_ctrl_dernent ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_correct_invent_mag'
Syntaxe :
pg_tempo_correct_invent_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_ecart_invent_mag'
Syntaxe :
pg_tempo_ecart_invent_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'Pg_tempo_st_edifour'


Procédure 'pg_tempo_envoi_invent_mag'
Syntaxe :
pg_tempo_envoi_invent_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_etat_ref'
Syntaxe :
pg_tempo_etat_ref ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'Pg_tempo_Etiq'
Syntaxe :
Pg_tempo_Etiq ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_fabrication'
Syntaxe :
pg_tempo_fabrication ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_Fact_D_Cinterne'
Syntaxe :
pg_tempo_Fact_D_Cinterne ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_gesfact'
Syntaxe :
pg_tempo_gesfact ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_lc_vis'
Syntaxe :
pg_tempo_lc_vis ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_marmotte'
Syntaxe :
pg_tempo_marmotte ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_mouchard'
Syntaxe :
pg_tempo_mouchard ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_oper_stock'
Syntaxe :
pg_tempo_oper_stock ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_pj_sai'
Syntaxe :
pg_tempo_pj_sai ()


Procédure 'pg_tempo_pj_vis'
Syntaxe :
pg_tempo_pj_vis ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_portcdemag'
Syntaxe :
pg_tempo_portcdemag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_reas_orig'
Syntaxe :
pg_tempo_reas_orig ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_reed_fac_gros'
Syntaxe :
pg_tempo_reed_fac_gros ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_reglem_recap'
Syntaxe :
pg_tempo_reglem_recap ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_remise_mag'
Syntaxe :
pg_tempo_remise_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_sav'
Syntaxe :
pg_tempo_sav ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_situ_vte'
Syntaxe :
pg_tempo_situ_vte ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_situvtedes'
Syntaxe :
pg_tempo_situvtedes ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_st_mag'
Syntaxe :
pg_tempo_st_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_st_maj_logi'
Syntaxe :
pg_tempo_st_maj_logi ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_stat'
Syntaxe :
pg_tempo_stat ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_stat_conso'
Syntaxe :
pg_tempo_stat_conso ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_Stat_conso_MagReplique'
Syntaxe :
pg_tempo_Stat_conso_MagReplique ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_stat_four'
Syntaxe :
pg_tempo_stat_four ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_stat_gestion'
Syntaxe :
pg_tempo_stat_gestion ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_Stat_HaussePx'
Syntaxe :
pg_tempo_Stat_HaussePx ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_stvalo'
Syntaxe :
pg_tempo_stvalo ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_taux_rupture_four'
Syntaxe :
pg_tempo_taux_rupture_four ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_traite_auto'
Syntaxe :
pg_tempo_traite_auto ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_util_confcent'
Syntaxe :
pg_tempo_util_confcent ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_temporaire'
Syntaxe :
pg_temporaire ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_versmonnaie1'
Syntaxe :
[ <Résultat> = ] pg_versmonnaie1 (<versmonnaie1_valeurorigine>)

Paramètres :
versmonnaie1_valeurorigine : <indiquez ici le rôle de versmonnaie1_valeurorigine>
Valeur de retour :
monétaire : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_versmonnaie2'
Syntaxe :
[ <Résultat> = ] pg_versmonnaie2 (<versmonnaie2_valeurorigine>)

Paramètres :
versmonnaie2_valeurorigine : <indiquez ici le rôle de versmonnaie2_valeurorigine>
Valeur de retour :
monétaire : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_ficVersExcel'
Syntaxe :
pg_ficVersExcel (<VueVersExcel_sCleFic>, <VueVersExcel_sNomFic>, <VueVersExcel_sListeRub>, <VueVersExcel_sLibRub>, <VueVersExcel_sFormatRub>, <VueVersExcel_sNomFicXls>, <VueVersExcel_sVersionExcel>)

Paramètres :
VueVersExcel_sCleFic : <indiquez ici le rôle de VueVersExcel_sCleFic>
VueVersExcel_sNomFic : <indiquez ici le rôle de VueVersExcel_sNomFic>
VueVersExcel_sListeRub : <indiquez ici le rôle de VueVersExcel_sListeRub>
VueVersExcel_sLibRub : <indiquez ici le rôle de VueVersExcel_sLibRub>
VueVersExcel_sFormatRub : <indiquez ici le rôle de VueVersExcel_sFormatRub>
VueVersExcel_sNomFicXls : <indiquez ici le rôle de VueVersExcel_sNomFicXls>
VueVersExcel_sVersionExcel : <indiquez ici le rôle de VueVersExcel_sVersionExcel>
Valeur de retour :
Aucune


Procédure 'Pg_Tempo_Stat_Etat_Commercial'
Syntaxe :
Pg_Tempo_Stat_Etat_Commercial ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Ini_lit_Gestion'
Syntaxe :
[ <Résultat> = ] pg_Ini_lit_Gestion (<Ini_lit_Gestion_Section>, <Ini_lit_Gestion_Entree>)

Paramètres :
Ini_lit_Gestion_Section : <indiquez ici le rôle de Ini_lit_Gestion_Section>
Ini_lit_Gestion_Entree : <indiquez ici le rôle de Ini_lit_Gestion_Entree>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Ini_Ecrit_Gestion'
Syntaxe :
pg_Ini_Ecrit_Gestion (<Section>, <Entree>, <Valeur>)

Paramètres :
Section : <indiquez ici le rôle de Section>
Entree : <indiquez ici le rôle de Entree>
Valeur : <indiquez ici le rôle de Valeur>
Valeur de retour :
Aucune


Procédure 'pg_tempo_Stat_Perf_RefFour'
Syntaxe :
pg_tempo_Stat_Perf_RefFour ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_ini_ecrit_choix'
Syntaxe :
pg_ini_ecrit_choix (<pg_ini_ecrit_choix_Section>, <pg_ini_ecrit_choix_Entree>, <pg_ini_ecrit_choix_Valeur>)

Paramètres :
pg_ini_ecrit_choix_Section : <indiquez ici le rôle de pg_ini_ecrit_choix_Section>
pg_ini_ecrit_choix_Entree : <indiquez ici le rôle de pg_ini_ecrit_choix_Entree>
pg_ini_ecrit_choix_Valeur : <indiquez ici le rôle de pg_ini_ecrit_choix_Valeur>
Valeur de retour :
Aucune


Procédure 'pg_ini_lit_choix'
Syntaxe :
[ <Résultat> = ] pg_ini_lit_choix (<pg_ini_lit_choix_Section>, <pg_ini_lit_choix_Entree>)

Paramètres :
pg_ini_lit_choix_Section : <indiquez ici le rôle de pg_ini_lit_choix_Section>
pg_ini_lit_choix_Entree : <indiquez ici le rôle de pg_ini_lit_choix_Entree>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_u_valoinvent'
Syntaxe :
pg_tempo_u_valoinvent ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_HpMag_Ref'
Syntaxe :
pg_tempo_HpMag_Ref ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Dern_Entree_Stock'


Procédure 'pg_Dern_Etiquette'
Syntaxe :
[ <Résultat> = ] pg_Dern_Etiquette (<PDern_Etiqette_e>)

Paramètres :
PDern_Etiqette_e : <indiquez ici le rôle de PDern_Etiqette_e>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_LecturePremier'
Syntaxe :
[ <Résultat> = ] pg_LecturePremier (<PFichier_c>, <PClé_c>)

Paramètres :
PFichier_c : <indiquez ici le rôle de PFichier_c>
PClé_c : <indiquez ici le rôle de PClé_c>
Valeur de retour :
chaîne : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_LectureDernier'


Procédure 'pg_Rech_Stock_Mag'


Procédure 'pg_QteEnCdeFour'
Syntaxe :
[ <Résultat> = ] pg_QteEnCdeFour (<PMag_c>, <PFam_c>, <PFour_c>, <PRef_c>)

Paramètres :
PMag_c : <indiquez ici le rôle de PMag_c>
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRef_c : <indiquez ici le rôle de PRef_c>
Valeur de retour :
réel : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Liste_Codes'


Procédure 'pg_Liste_Fourn'


Procédure 'pg_RechQteCent'


Procédure 'pg_tempo_cde_spe'
Syntaxe :
pg_tempo_cde_spe ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_fact_diff_centrale'
Syntaxe :
pg_tempo_fact_diff_centrale ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_comptachat_mag'
Syntaxe :
pg_tempo_comptachat_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_trancompta'
Syntaxe :
pg_tempo_trancompta ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_ecarts_restant'
Syntaxe :
pg_tempo_ecarts_restant ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_export_vtemag'
Syntaxe :
pg_tempo_export_vtemag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Liste_Fourn_Tous'
Syntaxe :
pg_Liste_Fourn_Tous (<PNomTab_c>)

Paramètres :
PNomTab_c : <indiquez ici le rôle de PNomTab_c>
Valeur de retour :
Aucune


Procédure 'pg_tempo_st_refmag'
Syntaxe :
pg_tempo_st_refmag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_STNONINT_ANCIEN1'
Syntaxe :
[ <Résultat> = ] pg_STNONINT_ANCIEN1 (<PFam_c>, <PFour_c>, <PRef_c>, <PMag_c>)

Paramètres :
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRef_c : <indiquez ici le rôle de PRef_c>
PMag_c : <indiquez ici le rôle de PMag_c>
Valeur de retour :
entier : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_reas_st_imp'
Syntaxe :
pg_tempo_reas_st_imp ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Rech_Qte_Prep'


Procédure 'pg_AssigneMag_Params'


Procédure 'pg_tempo_comptachat_st_mag'
Syntaxe :
pg_tempo_comptachat_st_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Tempo_Utilitaires'
Syntaxe :
pg_Tempo_Utilitaires ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_gest_vend'
Syntaxe :
pg_tempo_gest_vend ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_traite'
Syntaxe :
pg_tempo_traite ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_evo_ca_mag'
Syntaxe :
pg_tempo_evo_ca_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_li_recep'
Syntaxe :
pg_tempo_li_recep ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_STNONINT_ANCIEN2'
Syntaxe :
[ <Résultat> = ] pg_STNONINT_ANCIEN2 (<PFam_c>, <PFour_c>, <PRef_c>, <PMag_c>, <PDateDeb_c>)

Paramètres :
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRef_c : <indiquez ici le rôle de PRef_c>
PMag_c : <indiquez ici le rôle de PMag_c>
PDateDeb_c : <indiquez ici le rôle de PDateDeb_c>
Valeur de retour :
entier : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_RechDate_NbMois'


Procédure 'pg_STNONINT_ANCIEN3'


Procédure 'pg_tempo_suivi_det'
Syntaxe :
pg_tempo_suivi_det ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Liste_GroupFourn'


Procédure 'pg_RechDate_NbJours'
Syntaxe :
[ <Résultat> = ] pg_RechDate_NbJours (<PNbJours_e>)

Paramètres :
PNbJours_e : <indiquez ici le rôle de PNbJours_e>
Valeur de retour :
chaîne : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_partcamg'
Syntaxe :
pg_tempo_partcamg ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Rech_Num_PIECECPT'
Syntaxe :
[ <Résultat> = ] pg_Rech_Num_PIECECPT (<PNumCpt_e>)

Paramètres :
PNumCpt_e : <indiquez ici le rôle de PNumCpt_e>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_SuiviBdl'


Procédure 'pg_cof_lettre_vers_entier'
Syntaxe :
[ <Résultat> = ] pg_cof_lettre_vers_entier (<PLettre_c>)

Paramètres :
PLettre_c : <indiquez ici le rôle de PLettre_c>
Valeur de retour :
entier : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_cof_entier_vers_lettre'
Syntaxe :
[ <Résultat> = ] pg_cof_entier_vers_lettre (<PEntier_e>)

Paramètres :
PEntier_e : <indiquez ici le rôle de PEntier_e>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_cof_rech_zone'
Syntaxe :
[ <Résultat> = ] pg_cof_rech_zone (<PNumCoffre_e>, <PCol_e>, <PLg_c>)

Paramètres :
PNumCoffre_e : <indiquez ici le rôle de PNumCoffre_e>
PCol_e : <indiquez ici le rôle de PCol_e>
PLg_c : <indiquez ici le rôle de PLg_c>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_cof_coordonnées'
Syntaxe :
[ <Résultat> = ] pg_cof_coordonnées (<PCFour_c>, <PZone_e>, <PCoffre_e>, <PColLig_c>, <PMinMax_c>)

Paramètres :
PCFour_c : <indiquez ici le rôle de PCFour_c>
PZone_e : <indiquez ici le rôle de PZone_e>
PCoffre_e : <indiquez ici le rôle de PCoffre_e>
PColLig_c : <indiquez ici le rôle de PColLig_c>
PMinMax_c : <indiquez ici le rôle de PMinMax_c>
Valeur de retour :
entier : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Ajout_Mouchard'


Procédure 'pg_tempo_coffre'
Syntaxe :
pg_tempo_coffre ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_ini_lit_ediauto'
Syntaxe :
[ <Résultat> = ] pg_ini_lit_ediauto (<Section>, <Entree>, <fichier>)

Paramètres :
Section : <indiquez ici le rôle de Section>
Entree : <indiquez ici le rôle de Entree>
fichier : <indiquez ici le rôle de fichier>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_ini_ecrit_ediauto'
Syntaxe :
pg_ini_ecrit_ediauto (<PSection>, <PEntree>, <PValeur>, <Pfichier>)

Paramètres :
PSection : <indiquez ici le rôle de PSection>
PEntree : <indiquez ici le rôle de PEntree>
PValeur : <indiquez ici le rôle de PValeur>
Pfichier : <indiquez ici le rôle de Pfichier>
Valeur de retour :
Aucune


Procédure 'pg_cof_rend_CSTOCK'
Syntaxe :
[ <Résultat> = ] pg_cof_rend_CSTOCK (<PEtiqSaisie_c>, <PNumBonPrép_e>)

Paramètres :
PEtiqSaisie_c : <indiquez ici le rôle de PEtiqSaisie_c>
PNumBonPrép_e : <indiquez ici le rôle de PNumBonPrép_e>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_cof_rend_ancréf_CSTOCK'
Syntaxe :
[ <Résultat> = ] pg_cof_rend_ancréf_CSTOCK (<PEtiqSaisie_c>, <PNumBonPrép_e>)

Paramètres :
PEtiqSaisie_c : <indiquez ici le rôle de PEtiqSaisie_c>
PNumBonPrép_e : <indiquez ici le rôle de PNumBonPrép_e>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_cof_rend_gencod_CSTOCK'
Syntaxe :
[ <Résultat> = ] pg_cof_rend_gencod_CSTOCK (<PEtiqSaisie_c>, <PNumBonPrép_e>)

Paramètres :
PEtiqSaisie_c : <indiquez ici le rôle de PEtiqSaisie_c>
PNumBonPrép_e : <indiquez ici le rôle de PNumBonPrép_e>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_cof_affiche_emplacement'


Procédure 'pg_cof_rech_empl_preplili'


Procédure 'pg_tempo_reaselco'
Syntaxe :
pg_tempo_reaselco ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_impstide'


Procédure 'pg_cof_rech_empl_sgligne'
Syntaxe :
pg_cof_rech_empl_sgligne (<PNumBon_e>, <PAuMoinsUnEmpl_b>)

Paramètres :
PNumBon_e : <indiquez ici le rôle de PNumBon_e>
PAuMoinsUnEmpl_b : <indiquez ici le rôle de PAuMoinsUnEmpl_b>
Valeur de retour :
Aucune


Procédure 'pg_tempo_st_majmag'


Procédure 'pg_Rend_Etiquette'


Procédure 'pg_Rend_Gencode'
Syntaxe :
[ <Résultat> = ] pg_Rend_Gencode (<PGencode_c>, <PZLstEtiq_c>[, <PRechQtéSto_b>])

Paramètres :
PGencode_c : <indiquez ici le rôle de PGencode_c>
PZLstEtiq_c : <indiquez ici le rôle de PZLstEtiq_c>
PRechQtéSto_b : <indiquez ici le rôle de PRechQtéSto_b>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Rend_AncRéf'
Syntaxe :
[ <Résultat> = ] pg_Rend_AncRéf (<PAncRéf_c>, <PZLstEtiq_c>[, <PRechQtéSto_b>])

Paramètres :
PAncRéf_c : <indiquez ici le rôle de PAncRéf_c>
PZLstEtiq_c : <indiquez ici le rôle de PZLstEtiq_c>
PRechQtéSto_b : <indiquez ici le rôle de PRechQtéSto_b>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_u_mod_ref'
Syntaxe :
pg_tempo_u_mod_ref ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_imprefre'
Syntaxe :
pg_tempo_imprefre ()


Procédure 'pg_tempo_refre_vis'
Syntaxe :
pg_tempo_refre_vis ()


Procédure 'pg_tempo_improjet'
Syntaxe :
pg_tempo_improjet ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_SQLModifie'


Procédure 'pg_SQLRubriques'


Procédure 'pg_SQLValues'


Procédure 'pg_SQLSupprime'


Procédure 'pg_rectifheader'


Procédure 'pg_tempo_robbez'


Procédure 'pg_SQLEXEC'


Procédure 'pg_Rech_EtiqNonIntégré'


Procédure 'pg_tempo_edi_import'


Procédure 'pg_Change_Société'


Procédure 'pg_Rech_Vte_Mag'


Procédure 'pg_Création_Société'


Procédure 'pg_Calcul_TABTAR'


Procédure 'pg_Rech_CoefVte_Gam'


Procédure 'pg_Cof_Rech_Emplacemt'


Procédure 'pg_STNONINT'


Procédure 'pg_ini_ecrit_compta'
Syntaxe :
pg_ini_ecrit_compta (<pg_ini_ecrit_compta_Section>, <pg_ini_ecrit_compta_Entree>, <pg_ini_ecrit_compta_Valeur>)

Paramètres :
pg_ini_ecrit_compta_Section : <indiquez ici le rôle depg_ini_ecrit_compta_Section>
pg_ini_ecrit_compta_Entree : <indiquez ici le rôle de pg_ini_ecrit_compta_Entree>
pg_ini_ecrit_compta_Valeur : <indiquez ici le rôle de pg_ini_ecrit_compta_Valeur>
Valeur de retour :
Aucune


Procédure 'pg_ini_lit_compta'
Syntaxe :
[ <Résultat> = ] pg_ini_lit_compta (<pg_ini_lit_compta_Section>, <pg_ini_lit_compta_Entree>)

Paramètres :
pg_ini_lit_compta_Section : <indiquez ici le rôle de pg_ini_lit_compta_Section>
pg_ini_lit_compta_Entree : <indiquez ici le rôle de pg_ini_lit_compta_Entree>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Liste_Mag'


Procédure 'pg_Liste_GroupMag'


Procédure 'pg_Liste_Mag_Invent'


Procédure 'pg_tempo_st_pyrag'


Procédure 'pg_tempo_ecartpx'


Procédure 'pg_tempo_ctrlpx'


Procédure 'pg_Rech_QteCdeFour'


Procédure 'pg_GESTLIV_Initialisations'
Syntaxe :
[ <Résultat> = ] pg_GESTLIV_Initialisations (<POper_c>, <PDate_c>, <PFicImp_c>, <PLettreGestLiv_c>, <PLibMonnaie1_c>, <PLibMonnaie2_c>, <PMonnaie2_e>)

Paramètres :
POper_c : <indiquez ici le rôle de POper_c>
PDate_c : <indiquez ici le rôle de PDate_c>
PFicImp_c : <indiquez ici le rôle de PFicImp_c>
PLettreGestLiv_c : <indiquez ici le rôle de PLettreGestLiv_c>
PLibMonnaie1_c : <indiquez ici le rôle de PLibMonnaie1_c>
PLibMonnaie2_c : <indiquez ici le rôle de PLibMonnaie2_c>
PMonnaie2_e : <indiquez ici le rôle de PMonnaie2_e>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_GESTLIV_Connexion_Base'
Syntaxe :
pg_GESTLIV_Connexion_Base (<PLettre_c>, <PSté_c>)

Paramètres :
PLettre_c : <indiquez ici le rôle de PLettre_c>
PSté_c : <indiquez ici le rôle de PSté_c>
Valeur de retour :
Aucune


Procédure 'pg_Excel_Col'
Syntaxe :
[ <Résultat> = ] pg_Excel_Col (<PIndCol_e>)

Paramètres :
PIndCol_e : <indiquez ici le rôle de PIndCol_e>
Valeur de retour :
chaîne : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_CA_ST_IDEAL'
Syntaxe :
pg_tempo_CA_ST_IDEAL ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Rech_CoefCession'
Syntaxe :
pg_Rech_CoefCession ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_st_vis'
Syntaxe :
pg_tempo_st_vis ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Liste_TypeFourn'
Syntaxe :
pg_Liste_TypeFourn (<PNomListe_c>)

Paramètres :
PNomListe_c : <indiquez ici le rôle de PNomListe_c>
Valeur de retour :
Aucune


sg_decoup


cont_entrees_logibijou


lcdet_vis


PR_SERVI


identification


li_sel


ST_EDIFOUR


lc_vis


eq_vis


ST_EDIFOUR_ANNO


ctrl_dernent


Pr_ser


sg_vis


reas_st_mag


pr_vis


PATIENTEZ


SG_LIVR


I_PR_SG


I_ST_DERNENT_DET


I_PR_BON


I_DETMAG_CDE


I_recap_mag


I_LI_BON_CLEOR


I_li_conf_goldy


I_CD_BON


util_fen


St_oper


capecran


CINT_VIS


STPIECE_FIC


license


decrypte_fichier


eq_dep


saisiemp1


utrstockbl


ad_vis


cadrage_zebrat


fa_vis


EQ_COR


EQ_DUPLICATA_GESTLIV


coddd


imprims


CTRLPIECE_MOD


Choiximp


util_kyoeltron


motpasse


cadrage_zebra2


I_ST_DERNENT_MAG_REF


I_CD_BON_RELIQ


I_ST_DERNENT_LOGIBIJOU


I_ST_DERNENT_DETMAG


I_ST_DERNENT_DETMAG_REF


I_LI_BON_GOLDY


I_ST_DERNENT_MAGASIN


I_ST_DERNENT_RAYON


GLIV_VERIF


st1_vis