ODEISWEB
Manipulation des éléments accessibles

Pour manipuler un élément du composant (fenêtre, etc.) par programmation, il suffit de manipuler l'élément comme s'il s'agissait d'un élément créé dans le projet :

- pour appeler une procédure : utilisez la syntaxe habituelle :
ProcédureDuComposant(Param1,Param2)

- pour utiliser une classe : déclarer une variable du type de la classe :
MaVariable est un objet ClasseDuComposant
La variable s'utilise par la suite comme une variable objet normale.

- pour ouvrir une fenêtre : utilisez par exemple la fonction Ouvre en passant si nécessaire les paramètres attendus par cette fenêtre.
Ouvre(FenêtreDuComposant [, Param1, Param2])

- pour imprimer un état : utilisez la fonction iImprimeEtat en passant si nécessaire les paramètres attendus par cet état.
iImprimeEtat(EtatComposant [, Param1, Param2])

Les entrées/sorties du composant


Les entrées/sorties du composant

CA_WEB

Procedures globales de odeiscnt


CA_WEB


Procedures globales de odeiscnt

pg_assignemag

pg_balance

pg_barre_titre

pg_calcul_indice

pg_carrondi

pg_cartepuce

pg_Charge_pagegarde

pg_Code_CINTERNE

pg_CodeBarre128

pg_CODEBARREEAN13

pg_CodeBarreEan8

pg_Controle_password

pg_coulin

pg_couloff

pg_dateenclair

pg_Debug

pg_derniernumero

pg_echap

pg_Expens_Ref

pg_Facture_Imprime_A_Supprimer

pg_FicAjoute

pg_FicModifie

pg_FicSupprime

pg_fifo

pg_ImpCodeBarre

pg_Imprime_Facture

pg_Imprime_Word

pg_Ini_Ecrit

pg_ini_ecrit_com

pg_ini_ecrit_edi

pg_Ini_Ecrit_Inv

pg_ini_lit

pg_ini_lit_com

pg_ini_lit_edi

pg_Ini_Lit_Inv

pg_Init_pagegarde

pg_InitWord

pg_Lit_selmai

pg_MODIFLANGUE

pg_MoisEnClair

pg_MoisJour

pg_param_email

pg_params_email

pg_presence_carte

pg_RADProjetInit

pg_rech_qtemag

pg_rech_tarif

pg_rech_venmag

pg_rechindice1

pg_rechlecteur

pg_rechphoto

pg_remplace1

pg_Rend_Cle_EAN13

pg_Rend_CSTOCK

pg_Rend_DateCodee

pg_Rend_Euro

pg_Rend_NumCde

pg_Saisiemp

pg_sversion

pg_tempo_ac_ediint

pg_tempo_APV

pg_tempo_cc_vis

pg_tempo_cfrep_sai

pg_tempo_com_pro

pg_tempo_com_sai

pg_tempo_com_vendresp

pg_tempo_Compta

pg_tempo_conf_four

pg_tempo_conso_inv_maj

pg_tempo_controle_entrees_mag

pg_tempo_controle_invent_mag

pg_tempo_controle_transfert

pg_tempo_ctrl_dernent

pg_tempo_correct_invent_mag

pg_tempo_ecart_invent_mag

Pg_tempo_st_edifour

pg_tempo_envoi_invent_mag

pg_tempo_etat_ref

Pg_tempo_Etiq

pg_tempo_fabrication

pg_tempo_Fact_D_Cinterne

pg_tempo_gesfact

pg_tempo_lc_vis

pg_tempo_marmotte

pg_tempo_mouchard

pg_tempo_oper_stock

pg_tempo_pj_sai

pg_tempo_pj_vis

pg_tempo_portcdemag

pg_tempo_reas_orig

pg_tempo_reed_fac_gros

pg_tempo_reglem_recap

pg_tempo_remise_mag

pg_tempo_sav

pg_tempo_situ_vte

pg_tempo_situvtedes

pg_tempo_st_mag

pg_tempo_st_maj_logi

pg_tempo_stat

pg_tempo_stat_conso

pg_tempo_Stat_conso_MagReplique

pg_tempo_stat_four

pg_tempo_stat_gestion

pg_tempo_Stat_HaussePx

pg_tempo_stvalo

pg_tempo_taux_rupture_four

pg_tempo_traite_auto

pg_tempo_util_confcent

pg_temporaire

pg_versmonnaie1

pg_versmonnaie2

pg_ficVersExcel

Pg_Tempo_Stat_Etat_Commercial

pg_Ini_lit_Gestion

pg_Ini_Ecrit_Gestion

pg_tempo_Stat_Perf_RefFour

pg_ini_ecrit_choix

pg_ini_lit_choix

pg_tempo_u_valoinvent

pg_tempo_HpMag_Ref

pg_Dern_Entree_Stock

pg_Dern_Etiquette

pg_LecturePremier

pg_LectureDernier

pg_Rech_Stock_Mag

pg_QteEnCdeFour

pg_Liste_Codes

pg_Liste_Fourn

pg_RechQteCent

pg_tempo_cde_spe

pg_tempo_fact_diff_centrale

pg_tempo_comptachat_mag

pg_tempo_trancompta

pg_tempo_ecarts_restant

pg_tempo_export_vtemag

pg_Liste_Fourn_Tous

pg_tempo_st_refmag

pg_STNONINT_ANCIEN1

pg_tempo_reas_st_imp

pg_Rech_Qte_Prep

pg_AssigneMag_Params

pg_tempo_comptachat_st_mag

pg_Tempo_Utilitaires

pg_tempo_gest_vend

pg_tempo_traite

pg_tempo_evo_ca_mag

pg_tempo_li_recep

pg_STNONINT_ANCIEN2

pg_RechDate_NbMois

pg_STNONINT_ANCIEN3

pg_tempo_suivi_det

pg_Liste_GroupFourn

pg_RechDate_NbJours

pg_tempo_partcamg

pg_Rech_Num_PIECECPT

pg_tempo_SuiviBdl

pg_cof_lettre_vers_entier

pg_cof_entier_vers_lettre

pg_cof_rech_zone

pg_cof_coordonnées

pg_Ajout_Mouchard

pg_tempo_coffre

pg_ini_lit_ediauto

pg_ini_ecrit_ediauto

pg_cof_rend_CSTOCK

pg_cof_rend_ancréf_CSTOCK

pg_cof_rend_gencod_CSTOCK

pg_cof_affiche_emplacement

pg_cof_rech_empl_preplili

pg_tempo_reaselco

pg_tempo_impstide

pg_cof_rech_empl_sgligne

pg_tempo_st_majmag

pg_Rend_Etiquette

pg_Rend_Gencode

pg_Rend_AncRéf

pg_tempo_u_mod_ref

pg_tempo_imprefre

pg_tempo_refre_vis

pg_tempo_improjet

pg_SQLModifie

pg_SQLRubriques

pg_SQLValues

pg_SQLSupprime

pg_rectifheader

pg_tempo_robbez

pg_SQLEXEC

pg_Rech_EtiqNonIntégré

pg_tempo_edi_import

pg_Change_Société

pg_Rech_Vte_Mag

pg_Création_Société

pg_Calcul_TABTAR

pg_Rech_CoefVte_Gam

pg_Cof_Rech_Emplacemt

pg_STNONINT

pg_ini_ecrit_compta

pg_ini_lit_compta

pg_Liste_Mag

pg_Liste_GroupMag

pg_Liste_Mag_Invent

pg_tempo_st_pyrag

pg_tempo_ecartpx

pg_tempo_ctrlpx

pg_Rech_QteCdeFour

pg_GESTLIV_Initialisations

pg_GESTLIV_Connexion_Base

pg_Excel_Col

pg_tempo_CA_ST_IDEAL

pg_Rech_CoefCession

pg_tempo_st_vis

pg_Liste_TypeFourn

pg_ExclueFam_GestTaille

pg_rfidlitun

pg_REAS_STO_Initialisations

pg_Création_Table_CDE_ETIQ

pg_RfidLit_Plateau

pg_SemaineVersDate

pg_MajPhoto

pg_TraceSG

pg_tempo_st_inv_cor

pg_STNONINT_CENT

pg_RechQteMarmotte

pg_WebMajRef


Procédure 'pg_assignemag'
Procédure pg_assignemag()
Procedure permettant d'effectuer l'assigne du fichier
stock d'un magasin.
A partir d'un code magasin et du nom de son serveur :
. recherche existance fichier sur logibij/fichier si trouve
alors assigne.
. Si pas recherche existance sur logibij/fic+xxx si trouve
alors assigne.
. Si pas trouvee : reponse trouvemag a faux.


Procédure 'pg_balance'
Syntaxe :
pg_balance (<balance_poids>)

Paramètres :
balance_poids : <indiquez ici le rôle de balance_poids>
Valeur de retour :
Aucune


Procédure 'pg_barre_titre'
Syntaxe :
pg_barre_titre (<barre_titre_titre>)

Paramètres :
barre_titre_titre : <indiquez ici le rôle de barre_titre_titre>
Valeur de retour :
Aucune


Procédure 'pg_calcul_indice'
Syntaxe :
[ <Résultat> = ] pg_calcul_indice (<calcul_indice_ind>)

Paramètres :
calcul_indice_ind : <indiquez ici le rôle de calcul_indice_ind>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_carrondi'
Syntaxe :
pg_carrondi (<PPxVte_m>, <PRayon_c>, <PTypeArrondi_c>)

Paramètres :
PPxVte_m : <indiquez ici le rôle de PPxVte_m>
PRayon_c : <indiquez ici le rôle de PRayon_c>
PTypeArrondi_c : <indiquez ici le rôle de PTypeArrondi_c>
Valeur de retour :
Aucune


Procédure 'pg_cartepuce'
Syntaxe :
pg_cartepuce (<cartepuce_vendeur>, <cartepuce_motdepasse>)

Paramètres :
cartepuce_vendeur : <indiquez ici le rôle de cartepuce_vendeur>
cartepuce_motdepasse : <indiquez ici le rôle de cartepuce_motdepasse>
Valeur de retour :
Aucune


Procédure 'pg_Charge_pagegarde'
Syntaxe :
pg_Charge_pagegarde ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Code_CINTERNE'
Syntaxe :
pg_Code_CINTERNE (<code_cinterne_ValEntree>)

Paramètres :
code_cinterne_ValEntree : <indiquez ici le rôle de code_cinterne_ValEntree>
Valeur de retour :
Aucune


Procédure 'pg_CodeBarre128'
creation code barre code 128


Procédure 'pg_CODEBARREEAN13'
Procédure pg_CODEBARREEAN13()
***************************************
PROCEDURE D'IMPRESSION DE CODE BARRE
NORME : EAN 13
***************************************


Procédure 'pg_CodeBarreEan8'
Syntaxe :
pg_CodeBarreEan8 (<CodeBarreEan8_CodeBar>, <CodeBarreEan8_col>, <CodeBarreEan8_lig>[, <CodeBarreEan8_Hauteur>[, <CodeBarreEan8_Largeur>[, <CodeBarreEan8_HautDec>]]])

Paramètres :
CodeBarreEan8_CodeBar : <indiquez ici le rôle de CodeBarreEan8_CodeBar>
CodeBarreEan8_col : <indiquez ici le rôle de CodeBarreEan8_col>
CodeBarreEan8_lig : <indiquez ici le rôle de CodeBarreEan8_lig>
CodeBarreEan8_Hauteur : <indiquez ici le rôle de CodeBarreEan8_Hauteur>
CodeBarreEan8_Largeur : <indiquez ici le rôle de CodeBarreEan8_Largeur>
CodeBarreEan8_HautDec : <indiquez ici le rôle de CodeBarreEan8_HautDec>
Valeur de retour :
Aucune


Procédure 'pg_Controle_password'
Syntaxe :
[ <Résultat> = ] pg_Controle_password (<Controle_password_Nom_Fenetre>)

Paramètres :
Controle_password_Nom_Fenetre : <indiquez ici le rôle de Controle_password_Nom_Fenetre>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_coulin'
Syntaxe :
pg_coulin (<coulin_champ>)

Paramètres :
coulin_champ : <indiquez ici le rôle de coulin_champ>
Valeur de retour :
Aucune


Procédure 'pg_couloff'
Syntaxe :
pg_couloff (<couloff_champ>)

Paramètres :
couloff_champ : <indiquez ici le rôle de couloff_champ>
Valeur de retour :
Aucune


Procédure 'pg_dateenclair'
A partir d'un date sous la forme JJMMAAAA
pg_dateenclair procédure renvoie la date en clair
ex 14021997 devient Vendredi 14 Février 1997


Procédure 'pg_Debug'
Syntaxe :
pg_Debug (<Debug_Texte>)

Paramètres :
Debug_Texte : <indiquez ici le rôle de Debug_Texte>
Valeur de retour :
Aucune


Procédure 'pg_derniernumero'
Syntaxe :
[ <Résultat> = ] pg_derniernumero (<derniernumero_type>)

Paramètres :
derniernumero_type : <indiquez ici le rôle de derniernumero_type>
Valeur de retour :
entier : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_echap'
Syntaxe :
[ <Résultat> = ] pg_echap ()

Paramètres :
Aucun
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Expens_Ref'
Mise a longueur numetiq=7 caractères


Procédure 'pg_Facture_Imprime_A_Supprimer'
Syntaxe :
pg_Facture_Imprime_A_Supprimer ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_FicAjoute'
Syntaxe :
[ <Résultat> = ] pg_FicAjoute (<FicAjoute_NomFic>[, <FicAjoute_FlagErr>])

Paramètres :
FicAjoute_NomFic : <indiquez ici le rôle de FicAjoute_NomFic>
FicAjoute_FlagErr : <indiquez ici le rôle de FicAjoute_FlagErr>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_FicModifie'
Syntaxe :
[ <Résultat> = ] pg_FicModifie (<FicModifie_NomFic>[, <FicModifie_FlagErr>])

Paramètres :
FicModifie_NomFic : <indiquez ici le rôle de FicModifie_NomFic>
FicModifie_FlagErr : <indiquez ici le rôle de FicModifie_FlagErr>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_FicSupprime'
Syntaxe :
[ <Résultat> = ] pg_FicSupprime (<FicSupprime_NomFic>[, <FicSupprime_FlagErr>])

Paramètres :
FicSupprime_NomFic : <indiquez ici le rôle de FicSupprime_NomFic>
FicSupprime_FlagErr : <indiquez ici le rôle de FicSupprime_FlagErr>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_fifo'
recherche et lit le dernier article acheté (sur datefac)
a partir de (code-four+ref.four)
renvoi (resu_b=vrai et stock.nmagasin et stock.numetiq) si un article a été trouve


Procédure 'pg_ImpCodeBarre'
Syntaxe :
[ <Résultat> = ] pg_ImpCodeBarre (<ImpCodeBarre_Lig>, <ImpCodeBarre_Col>, <ImpCodeBarre_nHauteur>, <ImpCodeBarre_nLargeur>, <ImpCodeBarre_nHautDec>, <ImpCodeBarre_szCodeBarre>[, <ImpCodeBarre_Decalage>])

Paramètres :
ImpCodeBarre_Lig : <indiquez ici le rôle de ImpCodeBarre_Lig>
ImpCodeBarre_Col : <indiquez ici le rôle de ImpCodeBarre_Col>
ImpCodeBarre_nHauteur : <indiquez ici le rôle de ImpCodeBarre_nHauteur>
ImpCodeBarre_nLargeur : <indiquez ici le rôle de ImpCodeBarre_nLargeur>
ImpCodeBarre_nHautDec : <indiquez ici le rôle de ImpCodeBarre_nHautDec>
ImpCodeBarre_szCodeBarre : <indiquez ici le rôle de ImpCodeBarre_szCodeBarre>
ImpCodeBarre_Decalage : <indiquez ici le rôle de ImpCodeBarre_Decalage>
Valeur de retour :
réel : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Imprime_Facture'
Syntaxe :
[ <Résultat> = ] pg_Imprime_Facture (<Imprime_Facture_TypeDoc>, <Imprime_Facture_NoDoc>, <Imprime_Facture_Int_Dest>[, <Imprime_Facture_Tri>])

Paramètres :
Imprime_Facture_TypeDoc : <indiquez ici le rôle de Imprime_Facture_TypeDoc>
Imprime_Facture_NoDoc : <indiquez ici le rôle de Imprime_Facture_NoDoc>
Imprime_Facture_Int_Dest : <indiquez ici le rôle de Imprime_Facture_Int_Dest>
Imprime_Facture_Tri : <indiquez ici le rôle de Imprime_Facture_Tri>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Imprime_Word'
Syntaxe :
pg_Imprime_Word (<Imprime_Word_NumFac>[, <Imprime_Word_NomFicWord>])

Paramètres :
Imprime_Word_NumFac : <indiquez ici le rôle de Imprime_Word_NumFac>
Imprime_Word_NomFicWord : <indiquez ici le rôle de Imprime_Word_NomFicWord>
Valeur de retour :
Aucune


Procédure 'pg_Ini_Ecrit'
Syntaxe :
pg_Ini_Ecrit (<Ini_Ecrit_Section>, <Ini_Ecrit_Entree>, <Ini_Ecrit_Valeur>)

Paramètres :
Ini_Ecrit_Section : <indiquez ici le rôle de Ini_Ecrit_Section>
Ini_Ecrit_Entree : <indiquez ici le rôle de Ini_Ecrit_Entree>
Ini_Ecrit_Valeur : <indiquez ici le rôle de Ini_Ecrit_Valeur>
Valeur de retour :
Aucune


Procédure 'pg_ini_ecrit_com'
Syntaxe :
pg_ini_ecrit_com (<PSection>, <PEntree>, <PValeur>)

Paramètres :
PSection : <indiquez ici le rôle de PSection>
PEntree : <indiquez ici le rôle de PEntree>
PValeur : <indiquez ici le rôle de PValeur>
Valeur de retour :
Aucune


Procédure 'pg_ini_ecrit_edi'
Syntaxe :
pg_ini_ecrit_edi (<PSection>, <PEntree>, <PValeur>, <PCFourn>)

Paramètres :
PSection : <indiquez ici le rôle de PSection>
PEntree : <indiquez ici le rôle de PEntree>
PValeur : <indiquez ici le rôle de PValeur>
PCFourn : <indiquez ici le rôle de PCFourn>
Valeur de retour :
Aucune


Procédure 'pg_Ini_Ecrit_Inv'
Syntaxe :
pg_Ini_Ecrit_Inv (<Ini_Ecrit_Inv_Section>, <Ini_Ecrit_Inv_Entree>, <Ini_Ecrit_Inv_Valeur>)

Paramètres :
Ini_Ecrit_Inv_Section : <indiquez ici le rôle de Ini_Ecrit_Inv_Section>
Ini_Ecrit_Inv_Entree : <indiquez ici le rôle de Ini_Ecrit_Inv_Entree>
Ini_Ecrit_Inv_Valeur : <indiquez ici le rôle de Ini_Ecrit_Inv_Valeur>
Valeur de retour :
Aucune


Procédure 'pg_ini_lit'
Syntaxe :
[ <Résultat> = ] pg_ini_lit (<ini_lit_Section>, <ini_lit_Entree>)

Paramètres :
ini_lit_Section : <indiquez ici le rôle de ini_lit_Section>
ini_lit_Entree : <indiquez ici le rôle de ini_lit_Entree>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_ini_lit_com'
Syntaxe :
[ <Résultat> = ] pg_ini_lit_com (<PSection>, <PEntree>)

Paramètres :
PSection : <indiquez ici le rôle de PSection>
PEntree : <indiquez ici le rôle de PEntree>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_ini_lit_edi'
Syntaxe :
[ <Résultat> = ] pg_ini_lit_edi (<Section>, <Entree>, <CFourn>)

Paramètres :
Section : <indiquez ici le rôle de Section>
Entree : <indiquez ici le rôle de Entree>
CFourn : <indiquez ici le rôle de CFourn>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Ini_Lit_Inv'
Syntaxe :
[ <Résultat> = ] pg_Ini_Lit_Inv (<Ini_Lit_Inv_Section>, <Ini_Lit_Inv_Entree>)

Paramètres :
Ini_Lit_Inv_Section : <indiquez ici le rôle de Ini_Lit_Inv_Section>
Ini_Lit_Inv_Entree : <indiquez ici le rôle de Ini_Lit_Inv_Entree>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Init_pagegarde'
Syntaxe :
pg_Init_pagegarde ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_InitWord'
Syntaxe :
[ <Résultat> = ] pg_InitWord (<InitWord_Mail>, <InitWord_WordVisible>)

Paramètres :
InitWord_Mail : <indiquez ici le rôle de InitWord_Mail>
InitWord_WordVisible : <indiquez ici le rôle de InitWord_WordVisible>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Lit_selmai'
Syntaxe :
pg_Lit_selmai (<Lit_selmai_SELMAI>, <Lit_selmai_ch>)

Paramètres :
Lit_selmai_SELMAI : <indiquez ici le rôle de Lit_selmai_SELMAI>
Lit_selmai_ch : <indiquez ici le rôle de Lit_selmai_ch>
Valeur de retour :
Aucune


Procédure 'pg_MODIFLANGUE'
Syntaxe :
pg_MODIFLANGUE (<MODIFLANGUE_Groupe>, <MODIFLANGUE_Entree>, <MODIFLANGUE_Param>)

Paramètres :
MODIFLANGUE_Groupe : <indiquez ici le rôle de MODIFLANGUE_Groupe>
MODIFLANGUE_Entree : <indiquez ici le rôle de MODIFLANGUE_Entree>
MODIFLANGUE_Param : <indiquez ici le rôle de MODIFLANGUE_Param>
Valeur de retour :
Aucune


Procédure 'pg_MoisEnClair'
A partir d'un date sous la forme JJMMAAAA
pg_MoisEnClair procédure renvoie le mois en clair
ex 14021997 devient Février 1997


Procédure 'pg_MoisJour'
Syntaxe :
[ <Résultat> = ] pg_MoisJour (<MoisJour_ValEntree>)

Paramètres :
MoisJour_ValEntree : <indiquez ici le rôle de MoisJour_ValEntree>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_param_email'
NE PAS UTILISER CETTE FONCTION
UTILISER PARAMS_EMAIL()


Procédure 'pg_params_email'
Recherche parametres de connection email dans c:.txt


Procédure 'pg_presence_carte'
Syntaxe :
pg_presence_carte ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_RADProjetInit'
Syntaxe :
pg_RADProjetInit ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_rech_qtemag'
Syntaxe :
pg_rech_qtemag (<rech_qtemag_cinterne>, <rech_qtemag_cfourniss>, <rech_qtemag_reffour>, <rech_qtemag_cfamille>, <rech_qtemag_qtestomag_r>, <rech_qtemag_datemag_c>)

Paramètres :
rech_qtemag_cinterne : <indiquez ici le rôle de rech_qtemag_cinterne>
rech_qtemag_cfourniss : <indiquez ici le rôle de rech_qtemag_cfourniss>
rech_qtemag_reffour : <indiquez ici le rôle de rech_qtemag_reffour>
rech_qtemag_cfamille : <indiquez ici le rôle de rech_qtemag_cfamille>
rech_qtemag_qtestomag_r : <indiquez ici le rôle de rech_qtemag_qtestomag_r>
rech_qtemag_datemag_c : <indiquez ici le rôle de rech_qtemag_datemag_c>
Valeur de retour :
Aucune


Procédure 'pg_rech_tarif'
Syntaxe :
pg_rech_tarif (<RT_Contrmarq_c>, <RT_Cfamille_c>, <RT_Indice_e>)

Paramètres :
RT_Contrmarq_c : <indiquez ici le rôle de RT_Contrmarq_c>
RT_Cfamille_c : <indiquez ici le rôle de RT_Cfamille_c>
RT_Indice_e : <indiquez ici le rôle de RT_Indice_e>
Valeur de retour :
Aucune


Procédure 'pg_rech_venmag'
Syntaxe :
pg_rech_venmag (<rech_venmag_cinterne>, <rech_venmag_cfourniss>, <rech_venmag_reffour>, <rech_venmag_cfamille>, <rech_venmag_qtevenmag_r>)

Paramètres :
rech_venmag_cinterne : <indiquez ici le rôle de rech_venmag_cinterne>
rech_venmag_cfourniss : <indiquez ici le rôle de rech_venmag_cfourniss>
rech_venmag_reffour : <indiquez ici le rôle de rech_venmag_reffour>
rech_venmag_cfamille : <indiquez ici le rôle de rech_venmag_cfamille>
rech_venmag_qtevenmag_r : <indiquez ici le rôle de rech_venmag_qtevenmag_r>
Valeur de retour :
Aucune


Procédure 'pg_rechindice1'
Syntaxe :
pg_rechindice1 ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_rechlecteur'
Syntaxe :
[ <Résultat> = ] pg_rechlecteur ()

Paramètres :
Aucun
Valeur de retour :
entier : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_rechphoto'
Syntaxe :
pg_rechphoto (<rechphoto_cfourniss>, <rechphoto_reffour>, <rechphoto_photo>)

Paramètres :
rechphoto_cfourniss : <indiquez ici le rôle de rechphoto_cfourniss>
rechphoto_reffour : <indiquez ici le rôle de rechphoto_reffour>
rechphoto_photo : <indiquez ici le rôle de rechphoto_photo>
Valeur de retour :
Aucune


Procédure 'pg_remplace1'
Syntaxe :
pg_remplace1 (<remplace1_Ch>, <remplace1_ChIni>, <remplace1_ChRemp>)

Paramètres :
remplace1_Ch : <indiquez ici le rôle de remplace1_Ch>
remplace1_ChIni : <indiquez ici le rôle de remplace1_ChIni>
remplace1_ChRemp : <indiquez ici le rôle de remplace1_ChRemp>
Valeur de retour :
Aucune


Procédure 'pg_Rend_Cle_EAN13'
Syntaxe :
[ <Résultat> = ] pg_Rend_Cle_EAN13 (<Rend_Cle_EAN13_eCodeBar>)

Paramètres :
Rend_Cle_EAN13_eCodeBar : <indiquez ici le rôle de Rend_Cle_EAN13_eCodeBar>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Rend_CSTOCK'
Syntaxe :
[ <Résultat> = ] pg_Rend_CSTOCK (<Rend_CSTOCK_ValeurLue>[, <PDevidage_b>])

Paramètres :
Rend_CSTOCK_ValeurLue : <indiquez ici le rôle de Rend_CSTOCK_ValeurLue>
PDevidage_b : <indiquez ici le rôle de PDevidage_b>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Rend_DateCodee'
Syntaxe :
[ <Résultat> = ] pg_Rend_DateCodee (<Rend_DateCodee_Date>)

Paramètres :
Rend_DateCodee_Date : <indiquez ici le rôle de Rend_DateCodee_Date>
Valeur de retour :
chaîne fixe : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Rend_Euro'
Syntaxe :
[ <Résultat> = ] pg_Rend_Euro (<Rend_Euro_ValeurFF>)

Paramètres :
Rend_Euro_ValeurFF : <indiquez ici le rôle de Rend_Euro_ValeurFF>
Valeur de retour :
monétaire : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Rend_NumCde'
Syntaxe :
[ <Résultat> = ] pg_Rend_NumCde (<Rend_NumCde_Valeur_Entree>[, <Rend_NumCde_Sens_Inverse>])

Paramètres :
Rend_NumCde_Valeur_Entree : <indiquez ici le rôle de Rend_NumCde_Valeur_Entree>
Rend_NumCde_Sens_Inverse : <indiquez ici le rôle de Rend_NumCde_Sens_Inverse>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Saisiemp'
Syntaxe :
pg_Saisiemp ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_sversion'
Syntaxe :
pg_sversion (<sversion_opes_c>, <sversion_spack>)

Paramètres :
sversion_opes_c : <indiquez ici le rôle de sversion_opes_c>
sversion_spack : <indiquez ici le rôle de sversion_spack>
Valeur de retour :
Aucune


Procédure 'pg_tempo_ac_ediint'
Syntaxe :
pg_tempo_ac_ediint ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_APV'
Syntaxe :
pg_tempo_APV ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_cc_vis'
Syntaxe :
pg_tempo_cc_vis ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_cfrep_sai'
Syntaxe :
pg_tempo_cfrep_sai ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_com_pro'
Syntaxe :
pg_tempo_com_pro ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_com_sai'
Syntaxe :
pg_tempo_com_sai ()


Procédure 'pg_tempo_com_vendresp'
Syntaxe :
pg_tempo_com_vendresp ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_Compta'
Syntaxe :
pg_tempo_Compta ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_conf_four'
Syntaxe :
pg_tempo_conf_four ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_conso_inv_maj'
Syntaxe :
pg_tempo_conso_inv_maj ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_controle_entrees_mag'
Syntaxe :
pg_tempo_controle_entrees_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_controle_invent_mag'
Syntaxe :
pg_tempo_controle_invent_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_controle_transfert'
Syntaxe :
pg_tempo_controle_transfert ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_ctrl_dernent'
Syntaxe :
pg_tempo_ctrl_dernent ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_correct_invent_mag'
Syntaxe :
pg_tempo_correct_invent_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_ecart_invent_mag'
Syntaxe :
pg_tempo_ecart_invent_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'Pg_tempo_st_edifour'
Syntaxe :
Pg_tempo_st_edifour ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_envoi_invent_mag'
Syntaxe :
pg_tempo_envoi_invent_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_etat_ref'
Syntaxe :
pg_tempo_etat_ref ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'Pg_tempo_Etiq'
Syntaxe :
Pg_tempo_Etiq ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_fabrication'
Syntaxe :
pg_tempo_fabrication ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_Fact_D_Cinterne'
Syntaxe :
pg_tempo_Fact_D_Cinterne ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_gesfact'
Syntaxe :
pg_tempo_gesfact ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_lc_vis'
Syntaxe :
pg_tempo_lc_vis ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_marmotte'
Syntaxe :
pg_tempo_marmotte ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_mouchard'
Syntaxe :
pg_tempo_mouchard ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_oper_stock'
Syntaxe :
pg_tempo_oper_stock ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_pj_sai'
Syntaxe :
pg_tempo_pj_sai ()


Procédure 'pg_tempo_pj_vis'
Syntaxe :
pg_tempo_pj_vis ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_portcdemag'
Syntaxe :
pg_tempo_portcdemag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_reas_orig'
Syntaxe :
pg_tempo_reas_orig ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_reed_fac_gros'
Syntaxe :
pg_tempo_reed_fac_gros ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_reglem_recap'
Syntaxe :
pg_tempo_reglem_recap ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_remise_mag'
Syntaxe :
pg_tempo_remise_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_sav'
Syntaxe :
pg_tempo_sav ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_situ_vte'
Syntaxe :
pg_tempo_situ_vte ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_situvtedes'
Syntaxe :
pg_tempo_situvtedes ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_st_mag'
Syntaxe :
pg_tempo_st_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_st_maj_logi'
Syntaxe :
pg_tempo_st_maj_logi ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_stat'
Syntaxe :
pg_tempo_stat ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_stat_conso'
Syntaxe :
pg_tempo_stat_conso ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_Stat_conso_MagReplique'
Syntaxe :
pg_tempo_Stat_conso_MagReplique ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_stat_four'
Syntaxe :
pg_tempo_stat_four ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_stat_gestion'
Syntaxe :
pg_tempo_stat_gestion ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_Stat_HaussePx'
Syntaxe :
pg_tempo_Stat_HaussePx ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_stvalo'
Syntaxe :
pg_tempo_stvalo ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_taux_rupture_four'
Syntaxe :
pg_tempo_taux_rupture_four ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_traite_auto'
Syntaxe :
pg_tempo_traite_auto ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_util_confcent'
Syntaxe :
pg_tempo_util_confcent ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_temporaire'
Syntaxe :
pg_temporaire ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_versmonnaie1'
Syntaxe :
[ <Résultat> = ] pg_versmonnaie1 (<versmonnaie1_valeurorigine>)

Paramètres :
versmonnaie1_valeurorigine : <indiquez ici le rôle de versmonnaie1_valeurorigine>
Valeur de retour :
monétaire : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_versmonnaie2'
Syntaxe :
[ <Résultat> = ] pg_versmonnaie2 (<versmonnaie2_valeurorigine>)

Paramètres :
versmonnaie2_valeurorigine : <indiquez ici le rôle de versmonnaie2_valeurorigine>
Valeur de retour :
monétaire : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_ficVersExcel'
Syntaxe :
pg_ficVersExcel (<VueVersExcel_sCleFic>, <VueVersExcel_sNomFic>, <VueVersExcel_sListeRub>, <VueVersExcel_sLibRub>, <VueVersExcel_sFormatRub>, <VueVersExcel_sNomFicXls>, <VueVersExcel_sVersionExcel>)

Paramètres :
VueVersExcel_sCleFic : <indiquez ici le rôle de VueVersExcel_sCleFic>
VueVersExcel_sNomFic : <indiquez ici le rôle de VueVersExcel_sNomFic>
VueVersExcel_sListeRub : <indiquez ici le rôle de VueVersExcel_sListeRub>
VueVersExcel_sLibRub : <indiquez ici le rôle de VueVersExcel_sLibRub>
VueVersExcel_sFormatRub : <indiquez ici le rôle de VueVersExcel_sFormatRub>
VueVersExcel_sNomFicXls : <indiquez ici le rôle de VueVersExcel_sNomFicXls>
VueVersExcel_sVersionExcel : <indiquez ici le rôle de VueVersExcel_sVersionExcel>
Valeur de retour :
Aucune


Procédure 'Pg_Tempo_Stat_Etat_Commercial'
Syntaxe :
Pg_Tempo_Stat_Etat_Commercial ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Ini_lit_Gestion'
Syntaxe :
[ <Résultat> = ] pg_Ini_lit_Gestion (<Ini_lit_Gestion_Section>, <Ini_lit_Gestion_Entree>)

Paramètres :
Ini_lit_Gestion_Section : <indiquez ici le rôle de Ini_lit_Gestion_Section>
Ini_lit_Gestion_Entree : <indiquez ici le rôle de Ini_lit_Gestion_Entree>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Ini_Ecrit_Gestion'
Syntaxe :
pg_Ini_Ecrit_Gestion (<Section>, <Entree>, <Valeur>)

Paramètres :
Section : <indiquez ici le rôle de Section>
Entree : <indiquez ici le rôle de Entree>
Valeur : <indiquez ici le rôle de Valeur>
Valeur de retour :
Aucune


Procédure 'pg_tempo_Stat_Perf_RefFour'
Syntaxe :
pg_tempo_Stat_Perf_RefFour ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_ini_ecrit_choix'
Syntaxe :
pg_ini_ecrit_choix (<pg_ini_ecrit_choix_Section>, <pg_ini_ecrit_choix_Entree>, <pg_ini_ecrit_choix_Valeur>)

Paramètres :
pg_ini_ecrit_choix_Section : <indiquez ici le rôle de pg_ini_ecrit_choix_Section>
pg_ini_ecrit_choix_Entree : <indiquez ici le rôle de pg_ini_ecrit_choix_Entree>
pg_ini_ecrit_choix_Valeur : <indiquez ici le rôle de pg_ini_ecrit_choix_Valeur>
Valeur de retour :
Aucune


Procédure 'pg_ini_lit_choix'
Syntaxe :
[ <Résultat> = ] pg_ini_lit_choix (<pg_ini_lit_choix_Section>, <pg_ini_lit_choix_Entree>)

Paramètres :
pg_ini_lit_choix_Section : <indiquez ici le rôle de pg_ini_lit_choix_Section>
pg_ini_lit_choix_Entree : <indiquez ici le rôle de pg_ini_lit_choix_Entree>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_u_valoinvent'
Syntaxe :
pg_tempo_u_valoinvent ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_HpMag_Ref'
Syntaxe :
pg_tempo_HpMag_Ref ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Dern_Entree_Stock'
Syntaxe :
[ <Résultat> = ] pg_Dern_Entree_Stock (<PCfamille_c>, <PCfourniss_c>, <PReffour_c>, <PCInterne_c>[, <PAffMess_b>[, <PMessRet_c>]])

Paramètres :
PCfamille_c : <indiquez ici le rôle de PCfamille_c>
PCfourniss_c : <indiquez ici le rôle de PCfourniss_c>
PReffour_c : <indiquez ici le rôle de PReffour_c>
PCInterne_c : <indiquez ici le rôle de PCInterne_c>
PAffMess_b : <indiquez ici le rôle de PAffMess_b>
PMessRet_c : <indiquez ici le rôle de PMessRet_c>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Dern_Etiquette'
Syntaxe :
[ <Résultat> = ] pg_Dern_Etiquette (<PDern_Etiqette_e>)

Paramètres :
PDern_Etiqette_e : <indiquez ici le rôle de PDern_Etiqette_e>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_LecturePremier'
Syntaxe :
[ <Résultat> = ] pg_LecturePremier (<PFichier_c>, <PClé_c>)

Paramètres :
PFichier_c : <indiquez ici le rôle de PFichier_c>
PClé_c : <indiquez ici le rôle de PClé_c>
Valeur de retour :
chaîne : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_LectureDernier'
Syntaxe :
[ <Résultat> = ] pg_LectureDernier (<PFichier_c>, <PClé_c>)

Paramètres :
PFichier_c : <indiquez ici le rôle de PFichier_c>
PClé_c : <indiquez ici le rôle de PClé_c>
Valeur de retour :
chaîne : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Rech_Stock_Mag'
Syntaxe :
[ <Résultat> = ] pg_Rech_Stock_Mag (<PMag_c>, <PFam_c>, <PFour_c>, <PRef_c>[, <PRéfRemplacemt_b>[, <PAffMess_b>[, <PMessRet_c>]]])

Paramètres :
PMag_c : <indiquez ici le rôle de PMag_c>
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRef_c : <indiquez ici le rôle de PRef_c>
PRéfRemplacemt_b : <indiquez ici le rôle de PRéfRemplacemt_b>
PAffMess_b : <indiquez ici le rôle de PAffMess_b>
PMessRet_c : <indiquez ici le rôle de PMessRet_c>
Valeur de retour :
réel : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_QteEnCdeFour'
Syntaxe :
[ <Résultat> = ] pg_QteEnCdeFour (<PMag_c>, <PFam_c>, <PFour_c>, <PRef_c>[, <PAffMess_b>[, <PMessRet_c>]])

Paramètres :
PMag_c : <indiquez ici le rôle de PMag_c>
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRef_c : <indiquez ici le rôle de PRef_c>
PAffMess_b : <indiquez ici le rôle de PAffMess_b>
PMessRet_c : <indiquez ici le rôle de PMessRet_c>
Valeur de retour :
réel : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Liste_Codes'
Syntaxe :
pg_Liste_Codes (<PTypeCode_c>, <PNomTab_c>, <PFic_c>)

Paramètres :
PTypeCode_c : <indiquez ici le rôle de PTypeCode_c>
PNomTab_c : <indiquez ici le rôle de PNomTab_c>
PFic_c : <indiquez ici le rôle de PFic_c>
Valeur de retour :
Aucune


Procédure 'pg_Liste_Fourn'
Syntaxe :
pg_Liste_Fourn (<PNomTab_c>[, <PActif_b>[, <PGESTLIV_PCFour_c>]])

Paramètres :
PNomTab_c : <indiquez ici le rôle de PNomTab_c>
PActif_b : <indiquez ici le rôle de PActif_b>
PGESTLIV_PCFour_c : <indiquez ici le rôle de PGESTLIV_PCFour_c>
Valeur de retour :
Aucune


Procédure 'pg_RechQteCent'
Syntaxe :
[ <Résultat> = ] pg_RechQteCent (<PFam_c>, <PFour_c>, <PRef_c>[, <PRéfRemp_b>[, <PTail_r>[, <PAffMess_b>[, <PMessRet_c>]]]])

Paramètres :
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRef_c : <indiquez ici le rôle de PRef_c>
PRéfRemp_b : <indiquez ici le rôle de PRéfRemp_b>
PTail_r : <indiquez ici le rôle de PTail_r>
PAffMess_b : <indiquez ici le rôle de PAffMess_b>
PMessRet_c : <indiquez ici le rôle de PMessRet_c>
Valeur de retour :
réel : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_cde_spe'
Syntaxe :
pg_tempo_cde_spe ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_fact_diff_centrale'
Syntaxe :
pg_tempo_fact_diff_centrale ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_comptachat_mag'
Syntaxe :
pg_tempo_comptachat_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_trancompta'
Syntaxe :
pg_tempo_trancompta ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_ecarts_restant'
Syntaxe :
pg_tempo_ecarts_restant ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_export_vtemag'
Syntaxe :
pg_tempo_export_vtemag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Liste_Fourn_Tous'
Syntaxe :
pg_Liste_Fourn_Tous (<PNomTab_c>)

Paramètres :
PNomTab_c : <indiquez ici le rôle de PNomTab_c>
Valeur de retour :
Aucune


Procédure 'pg_tempo_st_refmag'
Syntaxe :
pg_tempo_st_refmag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_STNONINT_ANCIEN1'
Syntaxe :
[ <Résultat> = ] pg_STNONINT_ANCIEN1 (<PFam_c>, <PFour_c>, <PRef_c>, <PMag_c>)

Paramètres :
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRef_c : <indiquez ici le rôle de PRef_c>
PMag_c : <indiquez ici le rôle de PMag_c>
Valeur de retour :
entier : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_reas_st_imp'
Syntaxe :
pg_tempo_reas_st_imp ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Rech_Qte_Prep'
Syntaxe :
[ <Résultat> = ] pg_Rech_Qte_Prep (<PMag_c>, <PFam_c>, <PFour_c>, <PRef_c>[, <PRéfRemplacemt_b>[, <PTail_r>[, <PAffMess_b>[, <PMessRet_c>]]]])

Paramètres :
PMag_c : <indiquez ici le rôle de PMag_c>
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRef_c : <indiquez ici le rôle de PRef_c>
PRéfRemplacemt_b : <indiquez ici le rôle de PRéfRemplacemt_b>
PTail_r : <indiquez ici le rôle de PTail_r>
PAffMess_b : <indiquez ici le rôle de PAffMess_b>
PMessRet_c : <indiquez ici le rôle de PMessRet_c>
Valeur de retour :
réel : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_AssigneMag_Params'
Syntaxe :
pg_AssigneMag_Params (<AMP_Mag_c>, <AMP_Serveur_c>, <AMP_TrouveMag_b>)

Paramètres :
AMP_Mag_c : <indiquez ici le rôle de AMP_Mag_c>
AMP_Serveur_c : <indiquez ici le rôle de AMP_Serveur_c>
AMP_TrouveMag_b : <indiquez ici le rôle de AMP_TrouveMag_b>
Valeur de retour :
Aucune


Procédure 'pg_tempo_comptachat_st_mag'
Syntaxe :
pg_tempo_comptachat_st_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Tempo_Utilitaires'
Syntaxe :
pg_Tempo_Utilitaires ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_gest_vend'
Syntaxe :
pg_tempo_gest_vend ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_traite'
Syntaxe :
pg_tempo_traite ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_evo_ca_mag'
Syntaxe :
pg_tempo_evo_ca_mag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_li_recep'
Syntaxe :
pg_tempo_li_recep ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_STNONINT_ANCIEN2'
Syntaxe :
[ <Résultat> = ] pg_STNONINT_ANCIEN2 (<PFam_c>, <PFour_c>, <PRef_c>, <PMag_c>, <PDateDeb_c>)

Paramètres :
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRef_c : <indiquez ici le rôle de PRef_c>
PMag_c : <indiquez ici le rôle de PMag_c>
PDateDeb_c : <indiquez ici le rôle de PDateDeb_c>
Valeur de retour :
entier : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_RechDate_NbMois'
Syntaxe :
[ <Résultat> = ] pg_RechDate_NbMois (<PNbMois_e>[, <PDateDépart_c>])

Paramètres :
PNbMois_e : <indiquez ici le rôle de PNbMois_e>
PDateDépart_c : <indiquez ici le rôle de PDateDépart_c>
Valeur de retour :
chaîne : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_STNONINT_ANCIEN3'
Syntaxe :
[ <Résultat> = ] pg_STNONINT_ANCIEN3 (<PFam_c>, <PFour_c>, <PRef_c>, <PMag_c>, <PDateDeb_c>[, <PRéfRemplacemt_b>])

Paramètres :
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRef_c : <indiquez ici le rôle de PRef_c>
PMag_c : <indiquez ici le rôle de PMag_c>
PDateDeb_c : <indiquez ici le rôle de PDateDeb_c>
PRéfRemplacemt_b : <indiquez ici le rôle de PRéfRemplacemt_b>
Valeur de retour :
entier : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_suivi_det'
Syntaxe :
pg_tempo_suivi_det ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Liste_GroupFourn'
Syntaxe :
pg_Liste_GroupFourn (<PNomListe_c>)

Paramètres :
PNomListe_c : <indiquez ici le rôle de PNomListe_c>
Valeur de retour :
Aucune


Procédure 'pg_RechDate_NbJours'
Syntaxe :
[ <Résultat> = ] pg_RechDate_NbJours (<PNbJours_e>)

Paramètres :
PNbJours_e : <indiquez ici le rôle de PNbJours_e>
Valeur de retour :
chaîne : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_partcamg'
Syntaxe :
pg_tempo_partcamg ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Rech_Num_PIECECPT'
Syntaxe :
[ <Résultat> = ] pg_Rech_Num_PIECECPT (<PNumCpt_e>)

Paramètres :
PNumCpt_e : <indiquez ici le rôle de PNumCpt_e>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_SuiviBdl'
Syntaxe :
pg_tempo_SuiviBdl ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_cof_lettre_vers_entier'
Syntaxe :
[ <Résultat> = ] pg_cof_lettre_vers_entier (<PLettre_c>)

Paramètres :
PLettre_c : <indiquez ici le rôle de PLettre_c>
Valeur de retour :
entier : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_cof_entier_vers_lettre'
Syntaxe :
[ <Résultat> = ] pg_cof_entier_vers_lettre (<PEntier_e>)

Paramètres :
PEntier_e : <indiquez ici le rôle de PEntier_e>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_cof_rech_zone'
Syntaxe :
[ <Résultat> = ] pg_cof_rech_zone (<PNumCoffre_e>, <PCol_e>, <PLg_c>)

Paramètres :
PNumCoffre_e : <indiquez ici le rôle de PNumCoffre_e>
PCol_e : <indiquez ici le rôle de PCol_e>
PLg_c : <indiquez ici le rôle de PLg_c>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_cof_coordonnées'
Syntaxe :
[ <Résultat> = ] pg_cof_coordonnées (<PCFour_c>, <PZone_e>, <PCoffre_e>, <PColLig_c>, <PMinMax_c>)

Paramètres :
PCFour_c : <indiquez ici le rôle de PCFour_c>
PZone_e : <indiquez ici le rôle de PZone_e>
PCoffre_e : <indiquez ici le rôle de PCoffre_e>
PColLig_c : <indiquez ici le rôle de PColLig_c>
PMinMax_c : <indiquez ici le rôle de PMinMax_c>
Valeur de retour :
entier : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Ajout_Mouchard'
Syntaxe :
pg_Ajout_Mouchard (<PLibellé_c>, <PComment_c>[, <POpérateur_c>])

Paramètres :
PLibellé_c : <indiquez ici le rôle de PLibellé_c>
PComment_c : <indiquez ici le rôle de PComment_c>
POpérateur_c : <indiquez ici le rôle de POpérateur_c>
Valeur de retour :
Aucune


Procédure 'pg_tempo_coffre'
Syntaxe :
pg_tempo_coffre ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_ini_lit_ediauto'
Syntaxe :
[ <Résultat> = ] pg_ini_lit_ediauto (<Section>, <Entree>, <fichier>)

Paramètres :
Section : <indiquez ici le rôle de Section>
Entree : <indiquez ici le rôle de Entree>
fichier : <indiquez ici le rôle de fichier>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_ini_ecrit_ediauto'
Syntaxe :
pg_ini_ecrit_ediauto (<PSection>, <PEntree>, <PValeur>, <Pfichier>)

Paramètres :
PSection : <indiquez ici le rôle de PSection>
PEntree : <indiquez ici le rôle de PEntree>
PValeur : <indiquez ici le rôle de PValeur>
Pfichier : <indiquez ici le rôle de Pfichier>
Valeur de retour :
Aucune


Procédure 'pg_cof_rend_CSTOCK'
Syntaxe :
[ <Résultat> = ] pg_cof_rend_CSTOCK (<PEtiqSaisie_c>, <PNumBonPrép_e>)

Paramètres :
PEtiqSaisie_c : <indiquez ici le rôle de PEtiqSaisie_c>
PNumBonPrép_e : <indiquez ici le rôle de PNumBonPrép_e>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_cof_rend_ancréf_CSTOCK'
Syntaxe :
[ <Résultat> = ] pg_cof_rend_ancréf_CSTOCK (<PEtiqSaisie_c>, <PNumBonPrép_e>)

Paramètres :
PEtiqSaisie_c : <indiquez ici le rôle de PEtiqSaisie_c>
PNumBonPrép_e : <indiquez ici le rôle de PNumBonPrép_e>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_cof_rend_gencod_CSTOCK'
Syntaxe :
[ <Résultat> = ] pg_cof_rend_gencod_CSTOCK (<PEtiqSaisie_c>, <PNumBonPrép_e>)

Paramètres :
PEtiqSaisie_c : <indiquez ici le rôle de PEtiqSaisie_c>
PNumBonPrép_e : <indiquez ici le rôle de PNumBonPrép_e>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_cof_affiche_emplacement'
Syntaxe :
[ <Résultat> = ] pg_cof_affiche_emplacement (<PNumCof_e>, <PNumZone_e>, <PLigne_e>, <PColonne_e>, <PEmpl_e>)

Paramètres :
PNumCof_e : <indiquez ici le rôle de PNumCof_e>
PNumZone_e : <indiquez ici le rôle de PNumZone_e>
PLigne_e : <indiquez ici le rôle de PLigne_e>
PColonne_e : <indiquez ici le rôle de PColonne_e>
PEmpl_e : <indiquez ici le rôle de PEmpl_e>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_cof_rech_empl_preplili'
Syntaxe :
pg_cof_rech_empl_preplili (<PNumBon_e>, <PAuMoinsUnEmpl_b>)

Paramètres :
PNumBon_e : <indiquez ici le rôle de PNumBon_e>
PAuMoinsUnEmpl_b : <indiquez ici le rôle de PAuMoinsUnEmpl_b>
Valeur de retour :
Aucune


Procédure 'pg_tempo_reaselco'
Syntaxe :
pg_tempo_reaselco ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_impstide'
Syntaxe :
pg_tempo_impstide ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_cof_rech_empl_sgligne'
Syntaxe :
pg_cof_rech_empl_sgligne (<PNumBon_e>, <PAuMoinsUnEmpl_b>)

Paramètres :
PNumBon_e : <indiquez ici le rôle de PNumBon_e>
PAuMoinsUnEmpl_b : <indiquez ici le rôle de PAuMoinsUnEmpl_b>
Valeur de retour :
Aucune


Procédure 'pg_tempo_st_majmag'
Syntaxe :
pg_tempo_st_majmag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Rend_Etiquette'
Syntaxe :
[ <Résultat> = ] pg_Rend_Etiquette (<PArtSaisie_c>, <PTypeSaisie_c>, <PEtiquette_c>, <PZLstEtiq_c>[, <PRechQtéSto_b>])

Paramètres :
PArtSaisie_c : <indiquez ici le rôle de PArtSaisie_c>
PTypeSaisie_c : <indiquez ici le rôle de PTypeSaisie_c>
PEtiquette_c : <indiquez ici le rôle de PEtiquette_c>
PZLstEtiq_c : <indiquez ici le rôle de PZLstEtiq_c>
PRechQtéSto_b : <indiquez ici le rôle de PRechQtéSto_b>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Rend_Gencode'
Syntaxe :
[ <Résultat> = ] pg_Rend_Gencode (<PGencode_c>, <PZLstEtiq_c>[, <PRechQtéSto_b>])

Paramètres :
PGencode_c : <indiquez ici le rôle de PGencode_c>
PZLstEtiq_c : <indiquez ici le rôle de PZLstEtiq_c>
PRechQtéSto_b : <indiquez ici le rôle de PRechQtéSto_b>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Rend_AncRéf'
Syntaxe :
[ <Résultat> = ] pg_Rend_AncRéf (<PAncRéf_c>, <PZLstEtiq_c>[, <PRechQtéSto_b>])

Paramètres :
PAncRéf_c : <indiquez ici le rôle de PAncRéf_c>
PZLstEtiq_c : <indiquez ici le rôle de PZLstEtiq_c>
PRechQtéSto_b : <indiquez ici le rôle de PRechQtéSto_b>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_u_mod_ref'
Syntaxe :
pg_tempo_u_mod_ref ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_imprefre'
Syntaxe :
pg_tempo_imprefre ()


Procédure 'pg_tempo_refre_vis'
Syntaxe :
pg_tempo_refre_vis ()


Procédure 'pg_tempo_improjet'
Syntaxe :
pg_tempo_improjet ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_SQLModifie'
Syntaxe :
[ <Résultat> = ] pg_SQLModifie (<PNomFic_c>, <PClé_c>, <PValClé_c>, <PTypeClé_c>)

Paramètres :
PNomFic_c : <indiquez ici le rôle de PNomFic_c>
PClé_c : <indiquez ici le rôle de PClé_c>
PValClé_c : <indiquez ici le rôle de PValClé_c>
PTypeClé_c : <indiquez ici le rôle de PTypeClé_c>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_SQLRubriques'
Syntaxe :
[ <Résultat> = ] pg_SQLRubriques (<PNomFic_c>)

Paramètres :
PNomFic_c : <indiquez ici le rôle de PNomFic_c>
Valeur de retour :
chaîne : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_SQLValues'
Syntaxe :
[ <Résultat> = ] pg_SQLValues (<PNomFic_c>, <PLstRub_c>)

Paramètres :
PNomFic_c : <indiquez ici le rôle de PNomFic_c>
PLstRub_c : <indiquez ici le rôle de PLstRub_c>
Valeur de retour :
chaîne : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_SQLSupprime'
Syntaxe :
[ <Résultat> = ] pg_SQLSupprime (<PNomFic_c>, <PClé_c>, <PValClé_c>, <PTypeClé_c>)

Paramètres :
PNomFic_c : <indiquez ici le rôle de PNomFic_c>
PClé_c : <indiquez ici le rôle de PClé_c>
PValClé_c : <indiquez ici le rôle de PValClé_c>
PTypeClé_c : <indiquez ici le rôle de PTypeClé_c>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_rectifheader'
Syntaxe :
[ <Résultat> = ] pg_rectifheader ()

Paramètres :
Aucun
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_robbez'
Syntaxe :
pg_tempo_robbez ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_SQLEXEC'
Syntaxe :
[ <Résultat> = ] pg_SQLEXEC (<PReq_c>, <PNomReq_c>[, <PAffMess_b>[, <PMessRet_c>]])

Paramètres :
PReq_c : <indiquez ici le rôle de PReq_c>
PNomReq_c : <indiquez ici le rôle de PNomReq_c>
PAffMess_b : <indiquez ici le rôle de PAffMess_b>
PMessRet_c : <indiquez ici le rôle de PMessRet_c>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Rech_EtiqNonIntégré'
Syntaxe :
[ <Résultat> = ] pg_Rech_EtiqNonIntégré (<PFam_c>, <PFour_c>, <PRef_c>, <PMag_c>, <PDateDeb_c>[, <PRéfRemplacemt_b>])

Paramètres :
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRef_c : <indiquez ici le rôle de PRef_c>
PMag_c : <indiquez ici le rôle de PMag_c>
PDateDeb_c : <indiquez ici le rôle de PDateDeb_c>
PRéfRemplacemt_b : <indiquez ici le rôle de PRéfRemplacemt_b>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_edi_import'
Syntaxe :
pg_tempo_edi_import ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Change_Société'
Syntaxe :
pg_Change_Société (<PCSocNmag_c>, <PCSocNumEtiq_e>, <PCSocAncSoc_c>, <PCSocNvxSoc_c>, <PCSocQté_r>)

Paramètres :
PCSocNmag_c : <indiquez ici le rôle de PCSocNmag_c>
PCSocNumEtiq_e : <indiquez ici le rôle de PCSocNumEtiq_e>
PCSocAncSoc_c : <indiquez ici le rôle de PCSocAncSoc_c>
PCSocNvxSoc_c : <indiquez ici le rôle de PCSocNvxSoc_c>
PCSocQté_r : <indiquez ici le rôle de PCSocQté_r>
Valeur de retour :
Aucune


Procédure 'pg_Rech_Vte_Mag'
Syntaxe :
[ <Résultat> = ] pg_Rech_Vte_Mag (<PMag_c>, <PDateDeb_c>, <PDateFin_c>, <PFam_c>, <PFour_c>, <PRef_c>[, <PRéfRemplacemt_b>])

Paramètres :
PMag_c : <indiquez ici le rôle de PMag_c>
PDateDeb_c : <indiquez ici le rôle de PDateDeb_c>
PDateFin_c : <indiquez ici le rôle de PDateFin_c>
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRef_c : <indiquez ici le rôle de PRef_c>
PRéfRemplacemt_b : <indiquez ici le rôle de PRéfRemplacemt_b>
Valeur de retour :
réel : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Création_Société'
Syntaxe :
pg_Création_Société ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Calcul_TABTAR'
Syntaxe :
[ <Résultat> = ] pg_Calcul_TABTAR (<PTabTar_m>, <PPxAch_m>, <PCFour_c>, <PCFam_c>)

Paramètres :
PTabTar_m : <indiquez ici le rôle de PTabTar_m>
PPxAch_m : <indiquez ici le rôle de PPxAch_m>
PCFour_c : <indiquez ici le rôle de PCFour_c>
PCFam_c : <indiquez ici le rôle de PCFam_c>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Rech_CoefVte_Gam'
Syntaxe :
pg_Rech_CoefVte_Gam (<PRayon_c>, <PPxVte_m>, <PCoef_r>)

Paramètres :
PRayon_c : <indiquez ici le rôle de PRayon_c>
PPxVte_m : <indiquez ici le rôle de PPxVte_m>
PCoef_r : <indiquez ici le rôle de PCoef_r>
Valeur de retour :
Aucune


Procédure 'pg_Cof_Rech_Emplacemt'
Syntaxe :
[ <Résultat> = ] pg_Cof_Rech_Emplacemt (<PFam_c>, <PFour_c>, <PRéf_c>)

Paramètres :
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRéf_c : <indiquez ici le rôle de PRéf_c>
Valeur de retour :
chaîne : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_STNONINT'
Syntaxe :
[ <Résultat> = ] pg_STNONINT (<PFam_c>, <PFour_c>, <PRef_c>, <PMag_c>, <PDateDeb_c>, <PNbMoisStNonInt_e>[, <PRéfRemplacemt_b>[, <PAffMess_b>[, <PMessRet_c>]]])

Paramètres :
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRef_c : <indiquez ici le rôle de PRef_c>
PMag_c : <indiquez ici le rôle de PMag_c>
PDateDeb_c : <indiquez ici le rôle de PDateDeb_c>
PNbMoisStNonInt_e : <indiquez ici le rôle de PNbMoisStNonInt_e>
PRéfRemplacemt_b : <indiquez ici le rôle de PRéfRemplacemt_b>
PAffMess_b : <indiquez ici le rôle de PAffMess_b>
PMessRet_c : <indiquez ici le rôle de PMessRet_c>
Valeur de retour :
entier : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_ini_ecrit_compta'
Syntaxe :
pg_ini_ecrit_compta (<pg_ini_ecrit_compta_Section>, <pg_ini_ecrit_compta_Entree>, <pg_ini_ecrit_compta_Valeur>)

Paramètres :
pg_ini_ecrit_compta_Section : <indiquez ici le rôle depg_ini_ecrit_compta_Section>
pg_ini_ecrit_compta_Entree : <indiquez ici le rôle de pg_ini_ecrit_compta_Entree>
pg_ini_ecrit_compta_Valeur : <indiquez ici le rôle de pg_ini_ecrit_compta_Valeur>
Valeur de retour :
Aucune


Procédure 'pg_ini_lit_compta'
Syntaxe :
[ <Résultat> = ] pg_ini_lit_compta (<pg_ini_lit_compta_Section>, <pg_ini_lit_compta_Entree>)

Paramètres :
pg_ini_lit_compta_Section : <indiquez ici le rôle de pg_ini_lit_compta_Section>
pg_ini_lit_compta_Entree : <indiquez ici le rôle de pg_ini_lit_compta_Entree>
Valeur de retour :
variant : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Liste_Mag'
Syntaxe :
pg_Liste_Mag (<PNomTab_c>[, <PQueActif_b>[, <PNonOdeis_b>[, <PVérifFic_b>[, <PCocheON_b>]]]])

Paramètres :
PNomTab_c : <indiquez ici le rôle de PNomTab_c>
PQueActif_b : <indiquez ici le rôle de PQueActif_b>
PNonOdeis_b : <indiquez ici le rôle de PNonOdeis_b>
PVérifFic_b : <indiquez ici le rôle de PVérifFic_b>
PCocheON_b : <indiquez ici le rôle de PCocheON_b>
Valeur de retour :
Aucune


Procédure 'pg_Liste_GroupMag'
Syntaxe :
pg_Liste_GroupMag (<PNomListe_c>)

Paramètres :
PNomListe_c : <indiquez ici le rôle de PNomListe_c>
Valeur de retour :
Aucune


Procédure 'pg_Liste_Mag_Invent'
Syntaxe :
pg_Liste_Mag_Invent (<PNomTab_c>, <PCodeInv_c>[, <PQueActif_b>[, <PCocheON_b>]])

Paramètres :
PNomTab_c : <indiquez ici le rôle de PNomTab_c>
PCodeInv_c : <indiquez ici le rôle de PCodeInv_c>
PQueActif_b : <indiquez ici le rôle de PQueActif_b>
PCocheON_b : <indiquez ici le rôle de PCocheON_b>
Valeur de retour :
Aucune


Procédure 'pg_tempo_st_pyrag'
Syntaxe :
pg_tempo_st_pyrag ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_ecartpx'
Syntaxe :
pg_tempo_ecartpx ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_ctrlpx'
Syntaxe :
pg_tempo_ctrlpx ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Rech_QteCdeFour'
Syntaxe :
[ <Résultat> = ] pg_Rech_QteCdeFour (<PMag_c>, <PFam_c>, <PFour_c>, <PRef_c>[, <PTail_e>[, <PAffMess_b>[, <PMessRet_c>]]])

Paramètres :
PMag_c : <indiquez ici le rôle de PMag_c>
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRef_c : <indiquez ici le rôle de PRef_c>
PTail_e : <indiquez ici le rôle de PTail_e>
PAffMess_b : <indiquez ici le rôle de PAffMess_b>
PMessRet_c : <indiquez ici le rôle de PMessRet_c>
Valeur de retour :
réel : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_GESTLIV_Initialisations'
Syntaxe :
[ <Résultat> = ] pg_GESTLIV_Initialisations (<POper_c>, <PDate_c>, <PFicImp_c>, <PLettreGestLiv_c>, <PLibMonnaie1_c>, <PLibMonnaie2_c>, <PMonnaie2_e>)

Paramètres :
POper_c : <indiquez ici le rôle de POper_c>
PDate_c : <indiquez ici le rôle de PDate_c>
PFicImp_c : <indiquez ici le rôle de PFicImp_c>
PLettreGestLiv_c : <indiquez ici le rôle de PLettreGestLiv_c>
PLibMonnaie1_c : <indiquez ici le rôle de PLibMonnaie1_c>
PLibMonnaie2_c : <indiquez ici le rôle de PLibMonnaie2_c>
PMonnaie2_e : <indiquez ici le rôle de PMonnaie2_e>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_GESTLIV_Connexion_Base'
Syntaxe :
pg_GESTLIV_Connexion_Base (<PLettre_c>, <PSté_c>)

Paramètres :
PLettre_c : <indiquez ici le rôle de PLettre_c>
PSté_c : <indiquez ici le rôle de PSté_c>
Valeur de retour :
Aucune


Procédure 'pg_Excel_Col'
Syntaxe :
[ <Résultat> = ] pg_Excel_Col (<PIndCol_e>)

Paramètres :
PIndCol_e : <indiquez ici le rôle de PIndCol_e>
Valeur de retour :
chaîne : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_tempo_CA_ST_IDEAL'
Syntaxe :
pg_tempo_CA_ST_IDEAL ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Rech_CoefCession'
Syntaxe :
pg_Rech_CoefCession ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_tempo_st_vis'
Syntaxe :
pg_tempo_st_vis ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_Liste_TypeFourn'
Syntaxe :
pg_Liste_TypeFourn (<PNomListe_c>)

Paramètres :
PNomListe_c : <indiquez ici le rôle de PNomListe_c>
Valeur de retour :
Aucune


Procédure 'pg_ExclueFam_GestTaille'
Syntaxe :
[ <Résultat> = ] pg_ExclueFam_GestTaille (<PCFour_c>, <PSépTaille_c>[, <PCFam_c>[, <PRéfFour_c>[, <PTail_e>[, <PNumCde_e>]]]])

Paramètres :
PCFour_c : <indiquez ici le rôle de PCFour_c>
PSépTaille_c : <indiquez ici le rôle de PSépTaille_c>
PCFam_c : <indiquez ici le rôle de PCFam_c>
PRéfFour_c : <indiquez ici le rôle de PRéfFour_c>
PTail_e : <indiquez ici le rôle de PTail_e>
PNumCde_e : <indiquez ici le rôle de PNumCde_e>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_rfidlitun'
Syntaxe :
pg_rfidlitun ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_REAS_STO_Initialisations'
Syntaxe :
[ <Résultat> = ] pg_REAS_STO_Initialisations (<PDate_c>)

Paramètres :
PDate_c : <indiquez ici le rôle de PDate_c>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_Création_Table_CDE_ETIQ'
Syntaxe :
pg_Création_Table_CDE_ETIQ ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_RfidLit_Plateau'
Syntaxe :
[ <Résultat> = ] pg_RfidLit_Plateau (<pg_RfidLit_Plateau_PMode_c>[, <pg_RfidLit_Plateau_PArticle_c>])

Paramètres :
pg_RfidLit_Plateau_PMode_c : <indiquez ici le rôle de pg_RfidLit_Plateau_PMode_c>
pg_RfidLit_Plateau_PArticle_c : <indiquez ici le rôle de pg_RfidLit_Plateau_PArticle_c>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_SemaineVersDate'
Syntaxe :
[ <Résultat> = ] pg_SemaineVersDate (<PSemaine_e>, <PAnnée_e>, <PPremJour_b>)

Paramètres :
PSemaine_e : <indiquez ici le rôle de PSemaine_e>
PAnnée_e : <indiquez ici le rôle de PAnnée_e>
PPremJour_b : <indiquez ici le rôle de PPremJour_b>
Valeur de retour :
date : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_MajPhoto'
Syntaxe :
pg_MajPhoto (<PAncCfour_c>, <PAncReffour_c>, <PNouvCfour_c>, <PNouvReffour_c>)

Paramètres :
PAncCfour_c : <indiquez ici le rôle de PAncCfour_c>
PAncReffour_c : <indiquez ici le rôle de PAncReffour_c>
PNouvCfour_c : <indiquez ici le rôle de PNouvCfour_c>
PNouvReffour_c : <indiquez ici le rôle de PNouvReffour_c>
Valeur de retour :
Aucune


Procédure 'pg_TraceSG'
Syntaxe :
pg_TraceSG (<pg_TraceSG_PLibellé_c>)

Paramètres :
pg_TraceSG_PLibellé_c : <indiquez ici le rôle de pg_TraceSG_PLibellé_c>
Valeur de retour :
Aucune


Procédure 'pg_tempo_st_inv_cor'
Syntaxe :
pg_tempo_st_inv_cor ()

Paramètres :
Aucun
Valeur de retour :
Aucune


Procédure 'pg_STNONINT_CENT'
Syntaxe :
[ <Résultat> = ] pg_STNONINT_CENT (<PCFam_c>, <PCFour_c>, <PRéfFour_c>, <PTail_r>, <PDateDebBL_c>, <PDateFinBL_c>, <PLstMagNonInt_c>[, <PSelRéfRemp_b>[, <PAffMess_b>[, <PMess_c>]]])

Paramètres :
PCFam_c : <indiquez ici le rôle de PCFam_c>
PCFour_c : <indiquez ici le rôle de PCFour_c>
PRéfFour_c : <indiquez ici le rôle de PRéfFour_c>
PTail_r : <indiquez ici le rôle de PTail_r>
PDateDebBL_c : <indiquez ici le rôle de PDateDebBL_c>
PDateFinBL_c : <indiquez ici le rôle de PDateFinBL_c>
PLstMagNonInt_c : <indiquez ici le rôle de PLstMagNonInt_c>
PSelRéfRemp_b : <indiquez ici le rôle de PSelRéfRemp_b>
PAffMess_b : <indiquez ici le rôle de PAffMess_b>
PMess_c : <indiquez ici le rôle de PMess_c>
Valeur de retour :
Type indéterminé : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_RechQteMarmotte'
Syntaxe :
[ <Résultat> = ] pg_RechQteMarmotte (<PFam_c>, <PFour_c>, <PRef_c>[, <PRéfRemp_b>[, <PTail_r>[, <PAffMess_b>[, <PMessRet_c>]]]])

Paramètres :
PFam_c : <indiquez ici le rôle de PFam_c>
PFour_c : <indiquez ici le rôle de PFour_c>
PRef_c : <indiquez ici le rôle de PRef_c>
PRéfRemp_b : <indiquez ici le rôle de PRéfRemp_b>
PTail_r : <indiquez ici le rôle de PTail_r>
PAffMess_b : <indiquez ici le rôle de PAffMess_b>
PMessRet_c : <indiquez ici le rôle de PMessRet_c>
Valeur de retour :
réel : <indiquez ici les valeurs possibles ainsi que leur interprétation>


Procédure 'pg_WebMajRef'
Syntaxe :
pg_WebMajRef (<PFenEC_c>, <PDocumentXML_c>, <PCFam_c>, <PCFour_c>, <PRefFour_c>[, <PTail_r>[, <PInit_b>[, <PAffMess_b>[, <PMess_c>]]]])

Paramètres :
PFenEC_c : <indiquez ici le rôle de PFenEC_c>
PDocumentXML_c : <indiquez ici le rôle de PDocumentXML_c>
PCFam_c : <indiquez ici le rôle de PCFam_c>
PCFour_c : <indiquez ici le rôle de PCFour_c>
PRefFour_c : <indiquez ici le rôle de PRefFour_c>
PTail_r : <indiquez ici le rôle de PTail_r>
PInit_b : <indiquez ici le rôle de PInit_b>
PAffMess_b : <indiquez ici le rôle de PAffMess_b>
PMess_c : <indiquez ici le rôle de PMess_c>
Valeur de retour :
Aucune


Procédure 'pg_ODEISWEB_Initialisations'
Syntaxe :
[ <Résultat> = ] pg_ODEISWEB_Initialisations (<PDate_c>, <PLettre_c>, <PMag_c>)

Paramètres :
PDate_c : <indiquez ici le rôle de PDate_c>
PLettre_c : <indiquez ici le rôle de PLettre_c>
PMag_c : <indiquez ici le rôle de PMag_c>
Valeur de retour :
booléen : <indiquez ici les valeurs possibles ainsi que leur interprétation>